Subaru Forester Owners Forum

Subaru Forester Owners Forum (https://www.subaruforester.org/vbulletin/)
-   Interior and Electronics (https://www.subaruforester.org/vbulletin/f77/)
-   -   ('19+) Bluetooth interface on 2019 Forester big fail (https://www.subaruforester.org/vbulletin/f77/bluetooth-interface-2019-forester-big-fail-800775/)

handyguy 05-20-2019 12:27 PM

Bluetooth interface on 2019 Forester big fail
 
1 Attachment(s)
I have found the Android Auto interface to be a nearly useless mess especially for music. You cannot access your music library! Only playlists and recents/queue.
So I have fallen back to the Subaru bluetooth interface, however it does not work well either. I have tried two modern phones (lg, moto) and the symptoms are similar:
- Mostly cannot browse music library (icon is greyed out)
- If you can browse the library (by song, artist, album) when you finally select a tune etc, you get "no results available"
- The track controls often do no work (next track, etc.)
- A song playlist of length 1 often shows on screen with no info sometimes shows on car display, playing music from phone, but buttons are inoperative.

Anyone experiencing similar problems? Is there a new firmware patch for the head unit?

MFUNSHINE 05-20-2019 04:39 PM

I agree, that limitation within Android Auto is annoying. There is an update/visual overhaul coming to Android Auto in the near future, so I'm hoping they expand the options within Google Play Music then.

My workaround to this in AA is the google assistant. I use it within AA to play specific tracks/albums/artists by giving it a voice command. It won't replace the scroll/browse feature, but at least I can get what I want playing quickly.

OriginalTwoTone 05-20-2019 04:54 PM

Quote:

Originally Posted by handyguy (Post 7541679)
I have found the Android Auto interface to be a nearly useless mess especially for music. You cannot access your music library! Only playlists and recents/queue.
So I have fallen back to the Subaru bluetooth interface, however it does not work well either. I have tried two modern phones (lg, moto) and the symptoms are similar:
- Mostly cannot browse music library (icon is greyed out)
- If you can browse the library (by song, artist, album) when you finally select a tune etc, you get "no results available"
- The track controls often do no work (next track, etc.)
- A song playlist of length 1 often shows on screen with no info sometimes shows on car display, playing music from phone, but buttons are inoperative

Anyone experiencing similar problems? Is there a new firmware patch for the head unit?


oh shoot you mean you don't like everyone locking you out of staring at your screen scrolling through your music library instead of paying attention to the road? :surprise:

handyguy 05-20-2019 04:57 PM

No worse than typing an address into maps. In any case, doesn't work when you are stopped and parked, or any other many perfectly safe options. Or the passenger could be searching the library. They could also have had hyper links on a song to quickly (one click) access the artist/album, but that function is also not available.

handyguy 05-20-2019 04:59 PM

Android assistant is an option, but it hardly works when you are a google apps client. Also, my recall for my 30k song library is not what it used to be!

handyguy 05-22-2019 03:02 PM

ok, today's bluetooth issue: Phone connects, Subaru screen says there is a song playing, but there is no sound, and the song controls have no effect. This particular problem has occurred several times.

astrodeb 05-30-2019 05:42 PM

bluetooth, sound, AA issues
 
Hi--
This is my first post and I hope I am doing it correctly! I got my 2019 Forester in April and had the same issues. Short answer about the sound issue you are having : make sure the volume is turned up on your phone, and you may be getting drop outs when your phone is receiving emails or text notifications.

Now, for my story about this:
I took delivery of my Forester mid April and day of delivery they wired my phone to the car, contacts downloaded, etc etc. Then, on my own, I noticed all the issues mentioned here about weirdness with Android Auto, not being able to play my music, Google voice command dropping out and inconsistency with bluetooth. So I made an appt for my "Love" visit with Subaru. The tech there told me all these problems were 1) because the Starlink app was bad then 2) because my cable was bad 3) because my phone was bad 4)...when his phone wouldn't connect via bluetooth, that my bluetooth in the car was bad and I needed a service appointment (!).

Well, he was wrong about all of these things.

What I've determined by trial and error is that my phone (a Pixel2) connects *just fine* by bluetooth to my car AS LONG AS I do not have the cable plugged in trying to use Android Auto at the same time. I have to run things off my phone screen for the most part, but can use the steering column buttons to make calls, receive my texts read aloud to me while driving, and play all my audio books and media from the phone trouble free through the car speakers. I could even use Google maps on my phone if I wanted, but I will use Android Auto for the maps feature when I need it. I know its limitations now.

In short, it would be great if AA would work to also play my media content like I want it to, but for now, I'll take what I can get. :)


All times are GMT -8. The time now is 08:03 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome