Subaru Forester Owners Forum banner

1 - 3 of 3 Posts

·
Restricted Seller : Do not buy from me.
2009 2.5
Joined
·
109 Posts
Discussion Starter #1
Hi there, as usually used search, but anything was common.
'05 US market AT 2.5 XT 40k miles
So, everyday morning. Starting well. Cooling liquid is still haven't warmed up, but i never waited before. Slightly accelerating without troubles, but till probably 30-40 mi/h. When i press accelerator more i feel overloading the engine, it starts changing gear like on kick down, what is basically doesn't help. Lack of power and moreover, if i press accelerator more i hear light one, two explosions.

When it warmed up, problem is seems gone. But still think that no enough power i had before. I have K&N filter - now its clean and oiled, MAF is clean also, no ECU mistakes, OBD scanner doesn't show any mistakes also.



That how look my catalytic converter, maybe it could be jammed (as far as I know for subaru is not common).

Any possible issues? MAF, Lamda sensor, temperature sensor, catalytic converter, anything else?

Leo
 

·
Registered
2004 Forester XT 5MT
Joined
·
87 Posts
When I was car-shopping recently, the cat came up as one common item that fails in these cars.

How is the transmission fluid and is the level correct?
 

·
Restricted Seller : Do not buy from me.
2009 2.5
Joined
·
109 Posts
Discussion Starter #3
When I was car-shopping recently, the cat came up as one common item that fails in these cars.

How is the transmission fluid and is the level correct?
Valvoline 10W60, oil level ok, next change in couple of months

If the converter is jammed I should feel lack of power all the time, isn't it?
Yes, i have used it around 2 months with misfire problem, that theoretically could affect lambda and converter
 
1 - 3 of 3 Posts
Top