Subaru Forester Owners Forum banner

61 - 73 of 73 Posts

·
Registered
2005 Forester XT MT
Joined
·
58 Posts
I was attempting to adjust my brake pedal play and noticed this Mysterious Green Plug that appeared to be disconnected. Any idea what this might be for?

This is on a 2005 XT. I'm the second owner. Original owner had done a few mods so possible this is a custom plug.
 

Attachments

·
Registered
2007 Forester XT Manual
Joined
·
14 Posts
So that's what it is . . .

I just finished running the wiring for AEM AFR gauge and Oil Pressure gauge and came across these connectors. I wondered what they were for. Thank goodness I left them alone. Thanks for the info!
Kerry
 

·
Registered
2012 Forester Premium Automatic
Joined
·
2 Posts
I recently bought a 2012 subaru forester with the CEL already blinking/flashing, fans and relay turns on and off when the ignition is turned to ON position. On the 2012 forester this green connector with one wire is located behind the plastic kick panel driver side remove the plastic screw and look inside there, i disconnected that green connector no more CEL blinking/flashing, fans stop so as the relay clicking. Thank you everyone sharing this information.
 

·
Registered
2012 Forester Premium Automatic
Joined
·
2 Posts
2012 forester geen connector

Yes that green connector with one wire was plugged in when i bought it, i had discussed to the seller many times to fix and clear that flashing CEL but there is no code he said. it took me a while to find it until i saw a post a 2010 forester shows the green connector location. i took my 2012 forester to advance auto today and have it rescanned now it shows no DTC. i would like to attached a picture of the scanned screen that shows no codes found if you can please show me how to attach the pictures but before i disconnected that green connector there were multiple codes P1518, P0700, P0140, P1153, P1152, P0851 all those codes i mentioned were cleared... thanks

Note the green connector connection just to show how it was connected i did not pushed in all the way when i took the picture because i had a hard time disconnecting it.
 

Attachments

·
Registered
Joined
·
1 Posts
Forester XT Check engine light blinking fans turn On and Off

I have a 09 forester XT Automatic the check engine light is blinking fast and my radiator fans Turn On and Off when i have my ignition to on position,
This remains me of my 05 wrx when i had forgot to unplug Cobb flashing plugs....But i don't see any set up like this in my stock 09 XT...What Gives???
I had the exact same issue, totally freaked me out. I took it to 2 different shops to look at it, both said the car is fine but we can't figure out the light and fan thing. Then I took it to a dealer and they just reset it I guess and it's all better, never happened again, sure wish I knew what caused it though.
 

·
Registered
2000 Forester S
Joined
·
27 Posts
What are the two green plugs for? They are not connected but clearly one is female and the other male. Should they be connected and what would be the result?
546342
 
61 - 73 of 73 Posts
Top