Subaru Forester Owners Forum banner
1 - 4 of 4 Posts

· Registered
1998 Forester Auto
Joined
·
49 Posts
Discussion Starter · #1 ·
Hey all,

So my turn signals (and hazard flashers) suddenly stopped working last night. They would come on solidly if I pushed the handle in either direction, but not flash. Then this morning they stopped working altogether.

I don't know that much about cars in general, but I can follow directions and have fixed a number of issues myself. Does anyone know what this would be? Is it just a burned-out bulb? I've also read about a relay that might need to be replaced?

Thanks.
 

· Administrator
2016 & 2018 2.5i Premium CVT
Joined
·
21,797 Posts
There were a number of possiblities till you mentioned the "solidly on" situation. That pretty much isolates it to a crapped out flasher. The "solidly on" was probably its dying gasp.
 

· Registered
1998 Forester Auto
Joined
·
49 Posts
Discussion Starter · #3 ·
Thanks for the quick reply!

I found a How-To on here in the Knowledge Base about replacing it, so I'll give it a try tomorrow. Any tips or things I should know before I try to replace it would definitely be appreciated. Also, the author of the How-To says he wasn't able to remove the old relay. Any ideas about doing that?
 

· Administrator
2016 & 2018 2.5i Premium CVT
Joined
·
21,797 Posts
Relay and flasher are two different things. Your symptoms don't point toward relay problems. Relays don't have anything to do with flashing. They're on/off kinds of things.

Tell us what kind of Forester you have and we might be able to provide more detailed info. Best way to do this is to put it in your signature, so it's there with every post. Click Quick Links at the top of the page. Then click Edit Signature. Then tell us about your Forester: Year, model, transmission type.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top