Subaru Forester Owners Forum banner

1 - 8 of 8 Posts

·
K.I.T.T. meet A.L.I.C.E.
2008 Forester XT 4EAT
Joined
·
837 Posts
Discussion Starter #1
I'm trying to send an email to SOA via their "Contact us" form, but whenever I try to send it I get this:



Does anyone know how else I could send them an email? Or should I just try again tomorrow. I've tried a few times over the last 30 minutes to no avail.

P.S. I love how the failure in the "Contact Us" form leads you to a link for "Contact Us"
 

·
Premium Member
2013 Kia Rio Automatic
Joined
·
1,614 Posts
I just tried it and it worked for me??? What are you selecting in the
drop down window? I picked General Inquiries...
 

·
K.I.T.T. meet A.L.I.C.E.
2008 Forester XT 4EAT
Joined
·
837 Posts
Discussion Starter #3
I'd been trying "Product Recommendations"
 

·
Premium Member
2013 Kia Rio Automatic
Joined
·
1,614 Posts
I'd been trying "Product Recommendations"
eh, I would try what I did. At least you know someone will read it, they have to reroute it right? Or just wait and hopefully someone will fix it in the AM as I am sure those error messages are being logged.
 

·
K.I.T.T. meet A.L.I.C.E.
2008 Forester XT 4EAT
Joined
·
837 Posts
Discussion Starter #5
I just tried in the general inquiries and got the same result :(
 

·
Premium Member
2013 Kia Rio Automatic
Joined
·
1,614 Posts
I just tried in the general inquiries and got the same result :(
I hate to tell you this then, you and your computer are cursed! Naw, I don't know what to tell ya. :shrug::shrug::shrug::shrug:
 

·
Registered
Ah crap.. I'm back with my 05 XS
Joined
·
8,294 Posts
what browser are you two using? subaru's site uses flash? you both on v10 or v9?
 
1 - 8 of 8 Posts
Top