Subaru Forester Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2010 2.5x premium
Joined
·
31 Posts
Discussion Starter · #1 ·
One of the screws likes to fall out of the front passenger side Rally Armor mudflap. Any suggestions or tricks on how to get it to stay in ??...I notice it does not tighten..and if I unscrew it barely two turns it pops out....
 

·
Registered
2003 XS MT
Joined
·
5,484 Posts
Hmmm. I know on mine there is a metal bracket it screws in to. Well, one on of the screws. Probably different on your '10 though!
 

·
Registered
2016 Forester XT Touring
Joined
·
943 Posts
I had a issue where I didn't feel it was biting when I put mine in on the front and it wasn't getting tight, possibly same as you. I only got the screw in the front of the plastic retainer but I missed the back hole, b/c I couldn't see it. I took the screw out and readjusted the plastic retainer b/c I was trying to put the retainer over the metal piece and the plastic piece, making the retainer spread out too far and not allowing the screw to get in line. I moved the retainer to be over the metal only.
I swapped in a fresh retainer and ended up using the spread out retainer on the rear(the spot where you needed to use the plastic spacer and quicker to push on it).

Dave
 

·
Registered
2009 Forester X Premium
Joined
·
3,091 Posts
Did you remove the factory slash guards ? I had 1 screw that wouldnt catch because it was too short with the front factory flaps in place. Rears went on fine though with them so I left them on the back.
 
1 - 5 of 5 Posts
Top