Subaru Forester Owners Forum banner

1 - 20 of 77 Posts

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #1
Finally! Finished installing the Kenwood DNX5140 (using the Metra 95-8902, antenna adapter BAA26 and wiring kit BHA7552), Axxess steering wheel control adapter, 4 eclipse 6 1/2" door speakers (with adapter rings and wiring adapters from Crutchfield), 1 bazooka BTA10250D and some custom blue LED foot well lights.

Soldered all radio wiring connections and used heat shrink tubing with some extra wire wrap. This took a while. Assembling the Metra double din adapter was staight forward. Very pleased with the look. :rock:
 

Attachments

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #2
The GPS was mounted on top of a duct just behind the clock (see pic) using 3M velcro. The Axxess steering wheel control tucked nicely behind the environment control cluster. All steering wheel controls work perfect. As soon as power was turned on it programmed itself and started working great! Very happy with this product.:icon_biggrin: The stereo was a nice tight fit (no gaps - YAY!).
 

Attachments

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #3 (Edited)
Ran the power cable for the Bazooka through a nice grommet behind the left driver's kick panel (see pics). Just cut one slit in the empty grommet spot and used another wire to fish through the power wire (too lazy to take the fender well off :biggrin:). The kick plates were stubborn to pop out. There is a perfect little nook along the step plate to tuck the RCA preouts, remote turn on wire and power cables (see pics).
 

Attachments

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #4 (Edited)
The back seat wasn't too bad to get out (only the bottom was necessary). There are four bolts and a wiring plug in the middle (see pics). Then just pull straight up at each end of the seat to pop it out of the clips. Plenty of places under here for ground cable attachments. I routed my cables next to an existing harness to avoid any pressure points from the seat.
 

Attachments

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #5
The two plugs for the bazooka work out to be very convenient for quick removal, if extra cargo room is needed. There is a perfect little nook to tuck the cables out of sight right behind the seat.
 

Attachments

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #6
Went ahead and finished out the rear door speakers. The adapters only required one extra hole drilled and one hole in the door (the only permanent modification to the vehicle so far). I used dynamat and 10-24 stainless hardware to mount the adpaters with some thin weather stripping, too. Used #8 stainless sheet metal screws to affix the speakers to the adapter rings.

These speakers sound absolutely awesome in this vehicle. If I knew it was going to sound this good, probably would not have purchased any subwoofer.
 

Attachments

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #7 (Edited)
So far, I am VERY impressed with the Kenwood. Seems to be intuitive and feature rich. Nice to be able to make the controls any color you want. I just matched up the red color to the rest of the dash area. The one little snag I hit was not being able to activate the subwoofer preout. This was because I was not in stand by mode. Once that was figured out - OMG!! Sounds incredibly wicked!:lildevil: The dimmer for the screen can be synchronized with the GPS or adjusted manually. Threw a thumb drive with some music folders a few directories down from the root and BAM - it finds the music and sets it all up! Also, very convenient to have the thumb drive in the glove box.

Just threw the LED's in two spots. I can see that they need a little adjusting, but the effect is pretty cool. Anyways, that is all for now. :Banane35:
 

Attachments

·
Super Member
2010 Forester XT 4EAT
Joined
·
1,118 Posts
Hey, nice work. I never knew there was any other steering wheel control adapters out there. So the Axxess steering wheel control adapter works perfectly? I got the PAC Swi-jack and I can say from experience, it's far from perfect. Was yours hard to install? Was there a lot of programming instructions/steps to get it working?
 

·
Forum Member
2004 FXT
Joined
·
952 Posts
Only because i've done this before and have had to re-wire it... int his picture, you don't want to run your RCA cables along w/ your power cables. It will cause interference.



ps. your setup looks amazing :)
 

·
Registered
2018 2.0 FXT-Touring CVT
Joined
·
2,986 Posts
Looking good man.

Only thing that bugs me is the placement of the bazooka. It doesn't take up too much space for you?
 

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #11 (Edited)
Only because i've done this before and have had to re-wire it... int his picture, you don't want to run your RCA cables along w/ your power cables. It will cause interference.



ps. your setup looks amazing :)
I agree, but usually with just bass I don't worry about it. I remember when I first got into stereo systems many years ago, the remote turn on power wire was molded right into the signal cables (preouts). Used to always run the preouts separate from the battery ground cables. I think that the shielding and insulation properties of the wires/cables has improved alot over the years, though. Oddly enough, there is no noise/interference at all. Thanks for the compliment, too!
 

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #12 (Edited)
Hey, nice work. I never knew there was any other steering wheel control adapters out there. So the Axxess steering wheel control adapter works perfectly? I got the PAC Swi-jack and I can say from experience, it's far from perfect. Was yours hard to install? Was there a lot of programming instructions/steps to get it working?
Thanks! Yeah, Axxess is apparently made by Metra. All I did was wire it the way the instructions said to and apply power. It does the rest! I did no programming. Mute, forward/reverse, source/mode, volume all work perfectly. I did not expect to be so pleasantly surprised. Was not hard to install in my opinion. The only snag with this, is the connector illustration for the 2010 Forester plug is incorrect in their instructions. The pins they tell you to use are right, but their drawing is wrong. I have written to them about it and hopefully it will be corrected. Still fairly impressed with Metra, though.
 

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #13
Looking good man.

Only thing that bugs me is the placement of the bazooka. It doesn't take up too much space for you?
Thanks! It isn't too obtrusive to me, but the beauty of it is being able to pop it right out if you need the extra room. The system sounds awesome with or without the bazooka. I was hearing bass notes with the eclipse speakers that genuinely surprised me! The clarity is also exceptional. The bazooka just makes the bass ridiculous.:biggrin:
 

·
Registered
2010 Forester M
Joined
·
97 Posts
Looks good, I just did most of that stuff last weekend. I think I am going to order that axxess as I had absolutely no luck with the PAC unit.

one bit of advice on the GPS antenna. they probably included a little 2X2 metal/rubber pad to attach it to, it uses that as some sort of ground plane, you will get a little better reception if you use it, I did the same thing on my previous vehicle because I did not see that pad when I installed it. I never got the full 10 satellites, months later I found it and notices I was now getting the full 10 satellites locked.

same thing for sat radio antenna.

I ran the RCA cables down the middle and under the rug to the amp under the seat.

you can still get the cables with the remote turn on wire moulded in.
it is a real time saver and I don't think with the shielding of todays cables that it would cause interference. I taped an extra wire to mine and it works fine.

Looks great though, nice and invisible, well except for the bazooka.

could you post which axxess unit you have and where you bought it from, I want to get one myself? thank you

cheers
 

·
Registered
2018 2.0 FXT-Touring CVT
Joined
·
2,986 Posts
Thanks! It isn't too obtrusive to me, but the beauty of it is being able to pop it right out if you need the extra room. The system sounds awesome with or without the bazooka. I was hearing bass notes with the eclipse speakers that genuinely surprised me! The clarity is also exceptional. The bazooka just makes the bass ridiculous.:biggrin:
No doubt. Mine are molded into the cubby area behind the rear wheel wells... so it looks perfectly stock. I love the sound. Both amps are hidden under the seats (driver/passenger). The system sounds amazing and looks almost completely stock with an aftermarket headunit.
 

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #16
Looks good, I just did most of that stuff last weekend. I think I am going to order that axxess as I had absolutely no luck with the PAC unit.

one bit of advice on the GPS antenna. they probably included a little 2X2 metal/rubber pad to attach it to, it uses that as some sort of ground plane, you will get a little better reception if you use it, I did the same thing on my previous vehicle because I did not see that pad when I installed it. I never got the full 10 satellites, months later I found it and notices I was now getting the full 10 satellites locked.

same thing for sat radio antenna.

I ran the RCA cables down the middle and under the rug to the amp under the seat.

you can still get the cables with the remote turn on wire moulded in.
it is a real time saver and I don't think with the shielding of todays cables that it would cause interference. I taped an extra wire to mine and it works fine.

Looks great though, nice and invisible, well except for the bazooka.

could you post which axxess unit you have and where you bought it from, I want to get one myself? thank you

cheers
There is only one axxcess that I know of....found out about it here: Axxess Interface These folks sell them: http://www.sonicelectronix.com/item_22808_Axxess+ASWC.html
 

·
Super Member
2010 Forester XT 4EAT
Joined
·
1,118 Posts
Only because i've done this before and have had to re-wire it... int his picture, you don't want to run your RCA cables along w/ your power cables. It will cause interference.
It's funny because I competed in U.S.A.C. competitions with a couple of different cars for years and running the power wire with the RCA's was a big no-no just for that reason. Now I've found that with the last 3-4 cars my wife and I've had, that I don't have time and I'm to lazy to follow every single rule. I've run the power and RCA right with each other on the same side of the car and never had any problems with interference at all. Zero problems with any install, so I wouldn't worry about interference unless you're competing or something.
 

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #18
Ran into a size limitation on the USB read today. Seems like the folder size needs to be limited to about 3 gigs per folder or it just leaves some songs out. Also, did not have any luck trying to load a jpeg background image via USB. Will try burning to CD tomorrow. Still love this HU, though.
 

·
Super Member
2010 Forester XT 4EAT
Joined
·
1,118 Posts
Ran into a size limitation on the USB read today. Seems like the folder size needs to be limited to about 3 gigs per folder or it just leaves some songs out. Also, did not have any luck trying to load a jpeg background image via USB. Will try burning to CD tomorrow. Still love this HU, though.
Hey, I have the DDX516 and I had the same problem trying to load a Jpeg image for the background. The instructions were of no help and the only thing I could find on the internet was that someone said to make sure it's in the root directory and not in a folder. I had a flash drive and the picture was the only thing on it period and no luck. If you find out please let me know how.
 

·
Registered
2010 2.5X Limited
Joined
·
111 Posts
Discussion Starter #20
Hey, I have the DDX516 and I had the same problem trying to load a Jpeg image for the background. The instructions were of no help and the only thing I could find on the internet was that someone said to make sure it's in the root directory and not in a folder. I had a flash drive and the picture was the only thing on it period and no luck. If you find out please let me know how.
I found a note in the manual about not being able to manipulate the image when using a USB. Am wondering if it means not using a USB to load the image, as well. The way it was written is a little vague. Will try burning some images to cd and see if that works tonight.
 
1 - 20 of 77 Posts
Top