Subaru Forester Owners Forum banner

1 - 3 of 3 Posts

·
Registered
2003 Forester XS
Joined
·
6 Posts
Discussion Starter #1
Ok so I recently acquired a 2003 Forester XS, and today had my first problem....

After driving on dirt for approx 5 kms, I noticed a slight crackle from the car stereo (using cd), so I switched it off in case something had come loose. When I got back on to the bitumen I tried it again, and although the stereo is receiving power I wasnt getting any sound at all...

At this point I also noticed that my dashlights and driving lights werent working (along with the light on the driving light switch) - when I got home checked all fuses and fuse 12 (10 amp fuse) was blown.

I wondered if something had come loose on the dirt, so I removed the double din stereo and checked all connections including ground, but everything seemed fine, so I replaced fuse number 12 and tried again, but the fuse blew instantly when I turned the key to on position...

So ive searched for hours to find similar problem on any forums, and the following was all I found:

Originally Posted by Aussie '08 Forester
i tried to install a set of foggies into my '08 forester X but couldnt seem to get them to work using the loom already there im not sure what i did wrong
thats ok i can deal with no fog lights for the moment
but in the process i have done something to stop all my dash lights from working including the ones for the clock and A/C controlls
ive put everything back to how i found it ie. taken the switch out and dissconnected the lights them selves
checked all the fuses and all are fine ,
i did blow one 10amp fuse for the dash lighting while trying to work out what the 5 wires for the switch were and am thinking thats the problem
response:

Did a similar thing trying to get my foggies going in my MY03, ending up being a blown diode in the light control module, cost about $160 for the part, and took 3 days to work it out.
It seems a little strange that the stereo, driving lights and dash lights would be on the same circuit - in my old car if the dash lights went the brake lights were out too... in this case the brake lights are still working...

Im hoping this is just a relay issue or similar rather than a blown diode...

Any help would be very much appreciated - this is all the info I can provide as Im not much of a sparky...

cheers

Pete
 

·
Registered
2003 Forester XS
Joined
·
6 Posts
Discussion Starter #2
Ok so it seems it was just a ground issue with the stereo...

After replacing the fuse again all is ok - stereo, driving lights and dashlights all functioning normally now.

Thanks to whoever posted this DIY article on removing the double din OEM stereo!

(sorry, cant post links yet!)

cheers

Pete
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
39,799 Posts
Glad to hear you got it sorted out! :cool:

9 more posts & you'll have full posting privileges. :wink:

Bobby...

My MODding Journal
 
1 - 3 of 3 Posts
Top