Subaru Forester Owners Forum banner

1 - 19 of 19 Posts

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Discussion Starter #1
I have tried search on here, I can't find the info I need?

After the new engine was fitted I went to Powerstation for the remap.

During the remap Andy Cook said something about replacing a switch as there was hesitation.

To get to this you take out the Gear Lever to get at it.

I really couldn't hear all of what he was saying as it is noisy in there!

Anyway couple of days after the remap CEL came on.

I went to Foresters who plugged it in & the mesage was Heat Sensor Exhaust Temprature.

They replaced the sensor & reset the machine, no problem.

I really haven't pushed it since the new engine was fitted.

However, a couple of days ago on boost, it cut out then CEL came on, & a split second later poewer back.

When I started the engine the next day CEL off, driving well no problem.

Yesterday, I had the misfortune to be stuck on the A127 Jam into Southend On Sea.

I was behind a Van that kept his engine running the whole time, CEL came on & stayed on.

When I got onto the M25 on boost, cut out again.

I rang the Foresters & explained about the "switch?"


They said it is a starter switch by the gearbox & they will replace it for me.

Questions.

A) What is a Starter switch?
B) What does it do?
C) Will it solve the overboost?
D) Do you think it is a remap issue?

Thanks.

Regards



AM
 

·
Don, King of the parts diagram
MY11 WRX STi Sedan 6MT
Joined
·
5,870 Posts
It's probably the neutral switch, they are referring to that fits in the gearbox.

On my last mapping session mine was giving false readings. The tip of the plunger tends to wear down.

 

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Discussion Starter #3
Cheers Don,

You say you got false readings on your remap?

Did you change the switch & was everything OK again, no hesitation/cut out?

As usual a mine of information.

Kind regards


Alan
 

·
Don, King of the parts diagram
MY11 WRX STi Sedan 6MT
Joined
·
5,870 Posts
Yep, it showed up on the ecutek screens, switching on and off.

I changed the switch and had no apparent problems.

Testing it after removal the contact was very intermittent

If you do a google search for "Subaru neutral switch" there are many results on various BB's regarding all sorts of symptoms linked to it on an MT.

In the manual the listed trouble symptom is "erroneous idling".
 

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Discussion Starter #6
Changed the switch reset the ECU Orange light gone.

Took it up the Dual Carraigeway for a blast, bang cut out & CEL Light on again.

Plugged it into the Machine, Wastegate Selonoid fault.

Checked the hoses, part of one had perished, repaired that.

Took it for a blast.:biggrin: great!!


I was thinking of chopping the Foz for an Oil burner :huh:[/I]

I feel much better today though. :biggrin:


Regards



AM
 

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Discussion Starter #7
Well serves me right for being optimistic.:biggrin::biggrin::biggrin:

The Poxy CEL is back on!!

Car runs like dream.

Changed the Exhaust temprature Sensor.

Nuetral Switch by the Gearbox.

Fixed the perished hose on the 3 port boost selonoid.

:shrug::shrug::shrug:

What else could it be??

I remember when I had this before on a previous remap, once everything was checked over by PS, I got them to cancel the Exhaust Temprature function.

Over 100,000 miles of hassle free motoring later.

I think I'll get them to do that again unless, anyone has any other ideas.

Going to Forresters again this Friday for them to check with their machine.

This is hard work.

Regards




AM
 

·
Don, King of the parts diagram
MY11 WRX STi Sedan 6MT
Joined
·
5,870 Posts
Does an MY00 forester have a neutral switch?
In a word - Yes. :biggrin:


Alan,
Glad you got it sorted.
 

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Discussion Starter #10
Cheers Don,

I hope to have everything FINALLY bolted down by Friday.

The Foz has NEVER been so smooth.

Regards



AM


PS That Orange CEL!!:evilatyou:
 

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Discussion Starter #12
I'm running a catless up pipe.

As I said last remap cel kept on coming on, they canceled the exhaust temrature function, no cel & over 100,000 miles of hassle free motoring.

Cheers



Alan MaC
 

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Discussion Starter #13
All sorted!!

Powerstation got the Temprature Exhaust Gas CEL resolved once & for all.

They fitted a resistor to tell the ECU not to get intersted in the temprature till it gets to something silly like 800 C!!

No more Orange:woohoo::woohoo::woohoo:

Car goes like a dream.

New engine bedding in great, smooth as silk as a couple of Audis discovered today:biggrin::biggrin::biggrin:

Oh & a SAAB:biggrin:

The world is definitely a better place now all these niggly issues are sorted.


Happy MaC:biggrin::biggrin::biggrin:
 
A

·
Guest
Joined
·
0 Posts
Mine is running like a pig now, where is the starter switch located on MY00 cars please Don :biggrin:
I have an ECU code 12 and loads of hesitation, done a reset and all is ok for now :cool:
 

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Discussion Starter #15
Andy, is it the same by the gearbox as Don illustrated in mine?

Cheers



AM


How's the razors???:biggrin:
 

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Discussion Starter #16
It's probably the neutral switch, they are referring to that fits in the gearbox.

On my last mapping session mine was giving false readings. The tip of the plunger tends to wear down.

Andy,

This one.


AM
 
A

·
Guest
Joined
·
0 Posts
Thanks Alan, I wasn't sure if the neutral position sensor was the same as a starter switch :biggrin:
 

·
Don, King of the parts diagram
MY11 WRX STi Sedan 6MT
Joined
·
5,870 Posts
Thanks Alan, I wasn't sure if the neutral position sensor was the same as a starter switch :biggrin:
I've just dug out my 97 impreza manuals and they are in fact different.

There is in fact a link between the starter solenoid and the ECU (B135 terminal2) so that when the ignition key is turned to the "start" position the starter solenoid is energised and also a connection to the ECU is made. :biggrin:
 
A

·
Guest
Joined
·
0 Posts
Wonder why subaru invented that idea, just sounds like more stuff to go wrong :crazy:
 
1 - 19 of 19 Posts
Top