Subaru Forester Owners Forum banner

1 - 20 of 26 Posts

·
Registered
1998 stb
Joined
·
35 Posts
Discussion Starter #1
my 97 stb manual is runing a bit poo, it is hesitating under accelleration
and has missed once or twice ,almost banged my head on steering wheel .have checked filter and changed plugs and leads still no joy
the exhaust pops back sometimes when you lift off.does the car have any obd system if so what reader do i need ? any idears what to look for :confused:
 

·
Registered
1997 forester stb manual
Joined
·
1,435 Posts
mine did that once and it turned out to be the o2 sensor , was like a bucking bronco..... may not be that though but was first thing to spring to mind , could also be the maf:shrug:.....you need to get a diagnostic test done to be sure
 

·
JDM Foz [sold]
2016 Mercedes E220 AMG Auto
Joined
·
4,385 Posts
can you define hesitating a bit more and does it do it all the time?

I ask as mine does it occassionally usually when I havent used it for a few days. Did it on Friday morning as I hadnt used it since tuesday night. On saturday it was fine and has been as it got a good blast.
 

·
Registered
1998 stb
Joined
·
35 Posts
Discussion Starter #5
bucks when cold but when hot it just seams to be holding back when accelerating not alot but you can feel it and it just seams to be not reving as quickly as it did. can i read the fault codes with the black connectors on this model?
 

·
Registered
99 UK S-turbo
Joined
·
8,566 Posts
Yes plug together black and green connectors and read flash code, dead easy apart from having to grovel in the footwell, excellent instruction page on Jolly Green Monsters site.

Simon
 

·
Registered
1998 stb
Joined
·
35 Posts
Discussion Starter #7
no codes just a steady flash .the bucking when cold is bad today its when pulling away you get to 2000 rpm at part throttle( kangaroo petrol)then clears if you put your boot in and let the revs build up, air leak?checked all the hose clips around the maf ,turbo and under the intercooler no joy
 

·
Registered
1998 stb
Joined
·
35 Posts
Discussion Starter #9
did plugs and leads no joy what about tps?is the tps subaru only?its leaking oil now from somewhere under engine:chair:just to kick a man when he's down
 

·
Registered
1999 (UKDM) S-Turbo (LT) 4EAT
Joined
·
217 Posts
Mine did that too, though it's a MY99 S-Turbo so it might be different. I'm not particularly tech minded so I always trust the experts when I have a problem. The subaru dealer checked the codes, said it was the maf, it wasn't, then said it was the o2 sensor, it wasn't... changed the plugs and leads, no difference... I found it myself with the bonnet up on a dull grey evening. I could quite clearly see an occasional spark tracking from underneath the plug lead boot down the side of the ignition coil pack to one of the securing bolts. Removed the coil, cleaned it thoroughly and refitted, problem solved.
 

·
Registered
1998 stb
Joined
·
35 Posts
Discussion Starter #12
been to subaru today ,also said maf £365.51 i said no thanks. took to someone local they said fuel filter and that the coil pack has been painted by somebody a i should clean off the paint will do in the am let you chaps know thanks for everyones help
 

·
Registered
1998 stb
Joined
·
35 Posts
Discussion Starter #13
put a boost gauge on today just to see whats its doing. turbo boosts up to just over 1 bar then cuts back to 0.6 bar and that is the holding back. then sometimes it goes up to 1.2bar that cut engine for a moment then holds boost at about 0.8 bar any idears what is going on ?
can somebody let me know how the turbo is controlled and which valve does what .thanks Dom
 

·
Registered
1999 (UKDM) S-Turbo (LT) 4EAT
Joined
·
217 Posts
been to subaru today ,also said maf £365.51 i said no thanks. took to someone local they said fuel filter and that the coil pack has been painted by somebody a i should clean off the paint will do in the am let you chaps know thanks for everyones help
My money if I had any would be on the coilpack. Why has it been painted? Get that sorted and see what happens with the boost then.
 
A

·
Guest
Joined
·
0 Posts
The way to eliminate the boost from the rest of the problem is to fit a small section of pipe between the turbo compressor nipple and the actuator, this means it will only obtain 0.6 bar (8psi in old money) and should boost smoothly, if you still get jerking then it sounds like ignition/fueling.
If this cures the problem then the boost solonoid may need cleaning or could be shafted..
 

·
Registered
1998 stb
Joined
·
35 Posts
Discussion Starter #19
what level is the fuel cut then if iam getting 1.2 bar then cutting out ?i take it that its about 1.2 bar .the jerking at part throttle is a differant problem to the holding back i now think
 

·
Registered
1998 stb
Joined
·
35 Posts
Discussion Starter #20
on the fuel filter which pipe goes on where ?mine has pipe from fuel rail (engine) onto the in pipe and pipe runing up the car onto the out pipe is this right? to me that means its filtering fuel going back to the tank
 
1 - 20 of 26 Posts
Top