Subaru Forester Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2007 Forester XT Sports 5 speed
Joined
·
7 Posts
Discussion Starter #1
2007 XT, 5 speed, 129,000 miles.

It is getting worse. Accelerating with light to medium throttle, at 4,000 or so the motor intermittently "bogs" down and then catches up again as the revs go through to 5,000. I am afraid to test this with any more throttle.

Cruise control mantle light is blinking and the check engine light is on solid. Codes read were miss fires. This light comes and goes, but it is on more than off any more. I have seen this code for the last 2 years. If it is reset there is no change in the motor.

Plugs, timing belt are current.
 

·
Registered
2005 FXT
Joined
·
174 Posts
You’ve been having misfire DTCs for two years?

How many cylinders are misfiring?

Since the issue happens in the same RPM area every time, it sounds like a faulty crankshaft position (CKP) sensor. Could also be ignition coils or the camshaft position (CMP) sensor, possibly fuel injectors.

CKP sensor is super cheap (<$40) and should be replaced anyway with that amount of miles.
 

·
Registered
2005 FXT
Joined
·
174 Posts
This thing (CKP sensor) was a right PITA to get to, so I took it to a local shop that was open on Saturday. Saw two older WRXes parked next to each other, so I knew I’d be in good hands.

One of the WRX owners worked on getting it out and it was stuck in there. Literally broke in half and he had to carefully extract the lower metal portion out. Definitely was the original sensor. Might make sense to use a bit of PTFE lube to prevent it from getting stuck.

Car seems to be running a bit smoother now.
 
1 - 5 of 5 Posts
Top