Subaru Forester Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2003 XTi Cross Sports 4EAT :(
Joined
·
1,352 Posts
Discussion Starter #1 (Edited)
As the title states, I had my O2 sensor replaced and am not getting check engine light with code 32.

New OE spec sensor, I guess it could be faulty? This is the one I purchased.

http://www.subaruforester.org/vbull...05-impreza-front-f-ratio-oxygen-sensor-71436/

The reason I replaced it was sluggish acceleration/hesitation and several threads here suggested it be replaced.

The car DOES run better now but I am not happy with having the check engine light on. We reset the code but it comes back.

EDIT: For others here, I tried to follow the directions per this thread:

http://www.subaruforester.org/vbulletin/f66/o2-sensor-replaced-pics-inside-24496/

But couldn't break mine free and didn't have the right tools. I had Midas do it, in retrospect I should have done it myself and bought the tools.
 

·
Premium Member
2014 Impreza Ltd CVT
Joined
·
3,319 Posts
I got the same error when I replaced mine .... my hesitation was gone .... so I sent it back for a replacement ...... same problem.

Factory Heater was 1.1 ohm ..... this replacement has a heater value of 5.2 ohm.

The Oxygen sensor part is good, but after the 2nd replacement, I ordered the factory part from Jackie at Annapolis ..... much more expensive, but knowing it would fix my hesitation AND the code 32, my inspection is now completed and the ck engine light is gone.

Sorry for the bargain gone wrong !!!!
 

·
Registered
2003 XTi Cross Sports 4EAT :(
Joined
·
1,352 Posts
Discussion Starter #4
Could I continue to use it? Is it going to mess things up?

Labor to install it was a little pricey, I couldn't break the old one free so I had it done at Midas, but I still have the old one so I could put it back if need be now that they got it un-stuck from the cat.
 

·
Premium Member
2014 Impreza Ltd CVT
Joined
·
3,319 Posts
Other than the Ck eng light .... no. It's a heater failure. Your car will FAIL emissions, if your state checks for them.

I became very proficient at replacing it from above with either a 3/4 open end wrench. By the time I put in the Subaru one, I could do it in 10 mins.
 

·
Registered
2003 XTi Cross Sports 4EAT :(
Joined
·
1,352 Posts
Discussion Starter #6
Other than the Ck eng light .... no. It's a heater failure. Your car will FAIL emissions, if your state checks for them.

I became very proficient at replacing it from above with either a 3/4 open end wrench. By the time I put in the Subaru one, I could do it in 10 mins.
Good to know.

That's OK, I will use this sensor for the meantime then since the car is running smoother. I will swap out for the correct one when I can afford to purchase it.

I've not had to have my car in for emissions in the 4 years I've owned it. :shrug:

I could have totally replaced it had I had the correct tools, but had the car in for a brake fluid flush and just had them do the sensor while they had the car up on the lift.

Thanks for all the info, I did email the eBay seller seeing if they can get the correct part, otherwise I am asking for a refund.
 
1 - 6 of 6 Posts
Top