Subaru Forester Owners Forum banner

1 - 11 of 11 Posts

·
Registered
1999 s/tb
Joined
·
29 Posts
Discussion Starter #1
Hi,

Does anybody know how to remove the stereo from a 99 JDM, had a look and couldnt work it out.

Cheers

Loz
 

·
Premium Member
Joined
·
3,143 Posts
double din unit ?
 

·
Premium Member
98 JDM Stb Manual
Joined
·
3,787 Posts
You need to start from the central console around the gear stick and work up, the front facia will then just come off with care.
 

·
Registered
2004 Litchfield 330 STI
Joined
·
135 Posts
Fozz radio

Hi,

Does anybody know how to remove the stereo from a 99 JDM, had a look and couldnt work it out.

Cheers

Loz
Screws behind ashtray i think unclip plastic around gear stick, maybe two srews behind there up by ashtray area cant remember? then the centre consol plastic unclips, two screw up top two down bottom for double din cadge and tha should be it!!!!!!!!
 

·
JDM Foz [sold]
2016 Mercedes E220 AMG Auto
Joined
·
4,385 Posts
start from the centre arm rest/cubby hole inbetween the seats. Open the lid and there should be two plastic nipple type screw covers. Prise these off and there are two screws underneath.

Unscrew them. Then pull the plastic cover up and forward and this will remove the handbrake surround.

Next pull the gear lever surround out, again up and forward - it shouldnt be screwed in.

Next the stereo surround. remove the ashtray. The surround is only pressed in, however check there is no screw holding it in underneath the ashtray.

Now gently but firmly pull the bottom backward and upwards, there are four clips holding it in place.

Once thats off you'll see the screws to remove the stereo.

Theres a pic with these bits removed on this page: HDI SBC-D-SE Boost Controller Install : (mykp.co.uk)
 

·
Registered
1999 s/tb
Joined
·
29 Posts
Discussion Starter #8
Thanks everybody for the removal instructions it worked a treat.

But know i cant seem to get the black plastic surround back on, seems like something is in the way. Any ideas?

Loz
 

·
JDM Foz [sold]
2016 Mercedes E220 AMG Auto
Joined
·
4,385 Posts
you need to start at the top and push these in first, if its the first time the surround has been off then the pins are probably stiff. Once its been on and off a few time you wont have that problem.

Push the top ones in then the bottom ones.

As they say "Refit is reverse of removal" :biggrin:
 

·
Registered
1999 s/tb
Joined
·
29 Posts
Discussion Starter #10
Thanks, I tried that. But it seem like something was catching. I have removed the surround from the stereo. Its just like it cant fit over the stereo itself.

Loz
 

·
Registered
1999 s/tb
Joined
·
29 Posts
Discussion Starter #11
All sorted now :woohoo: managed to get the radio to sit flusher then the surround fitted better.

Thanks for all your advice, really helpful.

Cheers

Loz
 
1 - 11 of 11 Posts
Top