Subaru Forester Owners Forum banner

1 - 20 of 35 Posts

·
Registered
2009 Ralliart SST
Joined
·
231 Posts
Discussion Starter #1
so i bought a set and they work great when my fogs are off, but when i turn them both on a few issues comes up. first the high beam light on the dash is just barely on, like a headlight is out. then if i try to use the high beams they stick. they stay on even if i switch them off. i have to turn the headlights off and back on before they go back to lows. again this is only when the fogs are on. i checked all the grounds and connections...nothing. any ideas?
 

·
Premium Member
2009 Outback XT-B 5MT
Joined
·
10,254 Posts
You had a problem with your cheap ebay HID's? ORLY? OMG!!!

Do yourself a favor. Remove them and install good bulbs. Problem solved.
 

·
Registered
2014 Forester XT Touring CVT
Joined
·
800 Posts
yea im actually thinkin bout takin out my HIDs cause theyre blinding!!

but for your problem.. try disabling the DRLs (day running lights).. worked for me..
 

·
Registered
2009 Ralliart SST
Joined
·
231 Posts
Discussion Starter #4
yea im actually thinkin bout takin out my HIDs cause theyre blinding!!

but for your problem.. try disabling the DRLs (day running lights).. worked for me..

i did that at the same time i installed them :icon_frown:
 

·
Registered
2009 Ralliart SST
Joined
·
231 Posts
Discussion Starter #5
yea im actually thinkin bout takin out my HIDs cause theyre blinding!!

but for your problem.. try disabling the DRLs (day running lights).. worked for me..
i know, i know...but they work fine with the fogs off, so what gives?
 

·
Registered
2010 Forester 2.5XT SH Manual
Joined
·
97 Posts
i know, i know...but they work fine with the fogs off, so what gives?
I'm guessing here, but is it not possibly a problem with too much current going through the headlight switch? When the lights are on, just feel the top of the steering column. If it is hot, you have a problem there! If not, I would check if the lights are wired 100% correctly. HID's are supposed to draw less current than incandescent globes, so....
 

·
Registered
none none
Joined
·
8,844 Posts
Did you disable DRL by pulling the resistor or actually removing the module? Also you might have to do the mod to have the fogs function independently, this used to be discussed more often (its the way its all wired up from the factory).
 

·
Registered
2015 Forester CVT
Joined
·
62 Posts
+1 to trash them
I used them for a short time, they kept running hot and burning out.

Use the stock and add lights if you need more.
 

·
Premium Member
2014 Impreza Ltd CVT
Joined
·
3,319 Posts

·
Registered
2006 Forester XT
Joined
·
657 Posts
Sorry to be harsh, but I think you are just blaming the lights......

Could maybe change the title of the thread to " My HID kit works fine, I just don't know how to bypass the DRL's"
 

·
Registered
2009 Ralliart SST
Joined
·
231 Posts
Discussion Starter #12
Sorry to be harsh, but I think you are just blaming the lights......

Could maybe change the title of the thread to " My HID kit works fine, I just don't know how to bypass the DRL's"

i followed directions on here. i didn't remove the module but i did unplug it from there
 

·
Registered
2009 Ralliart SST
Joined
·
231 Posts
Discussion Starter #13

·
Registered
2014 CVT
Joined
·
824 Posts
the stock set up should turn the fogs off when you switch to high beams?? and from what i recall, its not legal to run both in most places, and i see no point in doing it, for the most part your high beams will wash out your fogs.................................and as others have said your drawing 2 much current thru the relay, so go back to your stock fog/high beam set up and as you said problem fixed........ just my 2 cents
 

·
Registered
2009 Ralliart SST
Joined
·
231 Posts
Discussion Starter #15
the stock set up should turn the fogs off when you switch to high beams?? and from what i recall, its not legal to run both in most places, and i see no point in doing it, for the most part your high beams will wash out your fogs.................................and as others have said your drawing 2 much current thru the relay, so go back to your stock fog/high beam set up and as you said problem fixed........ just my 2 cents

i've looked through all the headlight laws in indiana and i can't find anything that would make it illegal. on my R32 my fogs never kicked off when my high beams were on and that was factory.

at some point i'm going to try ferret's fix...i'm just going to have to grow a second brain to fully understand what he's saying :icon_razz:
 

·
Registered
2006 Forester XT
Joined
·
657 Posts
Boy, a lot of condescension about Ebay HID's......

Whatever makes you feel superior, it's all good.

S
 

·
Administrator
2004 Forester XT Premium 4EAT
Joined
·
29,449 Posts
You get what you pay for...
 
1 - 20 of 35 Posts
Top