Subaru Forester Owners Forum banner

1 - 7 of 7 Posts

·
Registered
1999 Forester S
Joined
·
131 Posts
Discussion Starter #1
My 99 forester has developed a problem letting the gas enter the tank. When I try to add gas to the tank, the gas hose from the filing station shuts off without letting much gas flow into the tank. Less than .4 tenths of a gallon will flow and the gas line shuts off. Doesn't matter if you manually hold the lever or use the auto fill notch. It can take 10/15 minutes to fill the tank. The dealer says that he thinks someone tried to steal gas and damaged the filler tube. He says he needs to replace the entire tank. Anyone have a simiiar problem or a suggestion. I've taken to filling a plastic tank and then emptying the plastic into to main tank. Still not fun.
 

·
Super Moderator
2007 Forester Sports XT 4EAT
Joined
·
35,714 Posts
Sounds familiar... try a forum search "tank vent", with the quotes. :wink:

Bobby...
 

·
Registered
none none
Joined
·
9,011 Posts
Its probably a rusted out fuel filler tube (or one of the associated pipes, you can check by pulling the fuel filler cover off, its in the right rear wheel well). This could definitely be your problem if you're in NY. Otherwise it could be a clogged vent tube, theres a number of threads regarding both problems on the forum.

Theres absolutely no reason to replace the tank unless the tank itself is leaking, all the other parts are replaceable separately.
 

·
Registered
2005 Impreza RS Wagon Auto
Joined
·
3,683 Posts
Its probably a rusted out fuel filler tube (or one of the associated pipes, you can check by pulling the fuel filler cover off, its in the right rear wheel well). This could definitely be your problem if you're in NY. Otherwise it could be a clogged vent tube, theres a number of threads regarding both problems on the forum.

Theres absolutely no reason to replace the tank unless the tank itself is leaking, all the other parts are replaceable separately.
+1
 

·
admin
2019 Outback 3.6R ..... 98 Forester S - Atl, GA
Joined
·
6,739 Posts
Its probably a rusted out fuel filler tube (or one of the associated pipes, you can check by pulling the fuel filler cover off, its in the right rear wheel well). This could definitely be your problem if you're in NY. Otherwise it could be a clogged vent tube, theres a number of threads regarding both problems on the forum.

Theres absolutely no reason to replace the tank unless the tank itself is leaking, all the other parts are replaceable separately.
+2
 

·
Registered
1999 Forester S
Joined
·
131 Posts
Discussion Starter #6
Thanks for the info. I didn't think I needed to replace entire tank. I'll check the archieves for the info on both possible solutions.:Banane02:
 

·
Registered
1999 Forester S
Joined
·
131 Posts
Discussion Starter #7
Well I've read the threads on Tank vent and some of the solutions require dropping the tank to get to the vent at the top and a $800 cost. I'm not happy. I usual cause was spider eggs in the vent line but getting to them was difficult. I'll try cleaning the vent lines and following the instruction in the thread. Thanks for pointing me in the right direction.
 
1 - 7 of 7 Posts
Top