Subaru Forester Owners Forum banner
1 - 10 of 10 Posts

·
Registered
2014 Forester 2.5i P 6 Speed manual
Joined
·
24 Posts
Discussion Starter · #1 ·
Does any have the factory recommended procedure for removal and reinstalling of the blower fan? I believe I have ice build up in mine. Crazy bad vibs on fan settings 3&4.
 

·
Registered
2017 WRX Limited
Joined
·
228 Posts
Does any have the factory recommended procedure for removal and reinstalling of the blower fan? I believe I have ice build up in mine. Crazy bad vibs on fan settings 3&4.
Are you out of warranty by way of extraordinarily high miles? If not why aren't you having a dealer fix this?
 

·
Registered
2014 Forester 2.5i P 6 Speed manual
Joined
·
24 Posts
Discussion Starter · #3 ·
Nope, less than 5k miles. Round trip to the dealer is ~150 miles.

Fan thawed out and vibration went away before I had to open it up.


This morning the fan did not run at all on any setting. Ran fine all weekend on a ~ 500 mile road trip. Shutting off the ignition and restarting did not clear the problem.

NOW its going back to the dealer!! Not too impressed Subaru....
 

·
Registered
2014 Forester 2.5i CVT
Joined
·
320 Posts
I'm beginning to think that there's a design flaw with 14 Forester's ventilation. People complain of "wet dog smell", moisture on the inside windshield, and now water in the fan.

Question: did you check if your cabin filter is dry or wet?

Please let us know if dealer found anything.
 

·
Registered
2014 Forester 2.5i P 6 Speed manual
Joined
·
24 Posts
Discussion Starter · #5 ·
I'm beginning to think that there's a design flaw with 14 Forester's ventilation. People complain of "wet dog smell", moisture on the inside windshield, and now water in the fan.

Question: did you check if your cabin filter is dry or wet?

Please let us know if dealer found anything.
I have noticed that unless the fan is on 3 or 4 the driver side window will frost a bit. I do get some wet dog smell occasionally but it seems to be directly proportional to the Great Pyrennes sitting behind me in the passenger seats. :icon_biggrin:

As far as heat quality it seems okay, last two vehicles were a '78 f-250 and an '86 toyota pickup. This car has more heat than those but I am kind of surprised it is not better. We are some what limited though anyway, too much heat and the dog complains. Sven is the only dog I know who likes having his head out the window at 55mph and -10F. I got him a pair of Doggles to avoid frozen corneas. :crazy:

I never got around to pulling the filter last time. I have never been all that good at removing automotive plastics without breaking stuff. Especially given the very low ambient temps right now (-35F) I am hesitant to try it. I emailed the dealer service manager and asked about an appointment on friday afternoon. I will check for a blown fuse when I get home, anything more than that and I think I am making the drive. Of course this couldn't have happend yesterday when I was down in Duluth.
 

·
Registered
2014 Forester 2.5i P 6 Speed manual
Joined
·
24 Posts
Discussion Starter · #7 ·
Yes I plan to check it tonight. Jen, my wife, said the fan vibrated again as before but then suddenly stopped. So i am thinking that maybe there was ice on a blade and it flew off, jammed the fan thus potentially popping a fuse.
 

·
Registered
2014 Forester 2.5i P 6 Speed manual
Joined
·
24 Posts
Discussion Starter · #8 ·
Well the problem resolved it self again before I took it to the dealer. I did get a call yesterday from the dealer that a new blower and reostat had come in for them to install. I did not request the parts order and they said it would be replaced under warrenty and I shouldn't be billed at all for it. We'll see what happens. We got a lot of snow and wind last night. I will see if the vibration problem came back, ie snow packed into heat system.
 

·
Registered
2014 Forester 2.5i P 6 Speed manual
Joined
·
24 Posts
Discussion Starter · #9 ·
vibration did not came back. However, yesterday on the way home from work the Check Engine, Traction Control Warning and Cruise Control indicator lights all came on. Retarting did not clear it. Called the dealer and they said to drive it down thursday for the heater blower swap and they would figure out the trouble lights too.
 

·
Registered
2015 Impreza 5-Door Sport Auto (CVT)
Joined
·
2,351 Posts
Sometimes disconnecting the battery for about half an hour will clear those lights also.

and make sure you disconnect BOTH negative and positive terminals.
 
1 - 10 of 10 Posts
Top