Subaru Forester Owners Forum banner

1 - 11 of 11 Posts

·
Registered
1999 Forester
Joined
·
57 Posts
Discussion Starter #1 (Edited)
Ill post more info a little bit but anyone have an estimate $$ fix?

Okay, so I was driving no problems anywhere, and sometimes when the car was cold and turning hard left I could hear a clanking from the front (I thought it was a frozen strut or something), skip forward to today and the moment I pull out of my drivway, CLANK, the thing that connects the front left driveshaft snaps. My dad and I took it apart and there's a broken star shaped circle thing. Looks like a reverse gear, (A torus shape with teeth on the inside of it). IDK what this part is called, and I'll try and get a picture of it. Basically we're having it towed to the shop, hopefully it's an easy fix. Any ideas on what exactly happened? I'm guessing I've hit too many bumps in the road and killed that part.
 

·
Registered
2009 Forester X Premium
Joined
·
3,091 Posts
Lets see some pictures of the damaged part, it sounds like the CV joint let go.
 

·
Registered
1999 Forester
Joined
·
57 Posts
Discussion Starter #5
Looks like it. I won't be able to get a picture until tomorrow morning but what's the repair procedure on this? Replace the whole axel or just that joint?
 

·
Premium Member
2008 Forester X Premium 5MT
Joined
·
8,070 Posts
That would be it, pics of your damaged one to confirm would be helpful.
 

·
Registered
1999 Forester
Joined
·
57 Posts
Discussion Starter #11
Sorry, my power went out the MOMENT I posted those up and couldn't fix anything. Also, I found some of the ball bearing lying on the road. I should have payed more attention to that clicking.
 
1 - 11 of 11 Posts
Top