Subaru Forester Owners Forum banner
1 - 4 of 4 Posts

·
Registered
2005 Legacy GT
Joined
·
3,679 Posts
Discussion Starter · #1 ·
Yesterday I installed the JDM clear corners on my 99'. The JDM turn signals fit fine, just they utilize a two prong socket whereas the stock USDM ones use a three prong socket. Me being the great engineer that I am :)cough cough:) took the JDM amber bulbs and (lightly) forced them into the stock three pronged socket. Then I duct taped the socket into the clear corner to hold in place as the socket is a bit smaller than the two pronged one that was supposed to fit in there. Fit everything, turned on the turn signals and hazards and everything worked fine. I went to work that night and when I left and turned on my lights I noticed that the left blinker signal in the dash was illuminated. Mind you, just a solid left arrow not blinking or anything. Went outside the car and noticed that the left front and rear blinker were both illuminated?!? Weird huh? Can anyone help me figure this out?

Right side works fine and blinks normally, but the driver's side turn signals stay constantly lit whenever the lights are on. Anyone know what could be causing this?? BTW if I do flip the turn signal down to the left a repeated clicking sound happens. It's the same sound as when you put your turn signal on normally, just sped up I'd say 3-5 times, and only on the left side. If anyone has any idea how to fix this or what could be wrong I'd greatly appreciate it. The clear corners look great during the day but not at night when the left side of my car is lit up like a christmas tree :icon_eek: .
 

·
Registered
08 LL Bean Edition
Joined
·
22 Posts
USDM has 3 wires because they have the corner lights on as parking lights. All you need to do id find out what wire is for the parking light, and eliminate it.
 

·
Registered
2005 Legacy GT
Joined
·
3,679 Posts
Discussion Starter · #3 ·
thanks, I might try that. Weird how the driver's side works fine though?

Today with the lights off when I turn on the left turn signal, all my dash light start blinking on and off?

Any one else know what might be wrong?
 

·
Registered
2005 Legacy GT
Joined
·
3,679 Posts
Discussion Starter · #4 ·
disregard. Put back in the original USDM bulbs (27 watt as opposed to 21), and toyed with the one socket a bit and everything is working fine. Will post some pics in the "Modz" gallery soon with some other shots of the recently debadged trunk and subwoofer. :Banane35:
 
1 - 4 of 4 Posts
Top