Subaru Forester Owners Forum banner

1 - 2 of 2 Posts

·
Registered
1997 Forester T/Tb
Joined
·
1 Posts
Discussion Starter #1
Hey people

Pete here from New Zealand, just bought my first subaru and now i am thinking what have i done....lol

We have a 1997 Forester T/Tb so its the one with the EJ20T in it, automatic, electric everything inside, very nice car to drive and be in...

I have a problem though, it looks like my ignition coil, leads or plugs have packed it in, the car runs fine for abit ,but under hard acceleration it hestitates, splutters, smokes unburnt fuel, bascially runs like a 2 legged dog, not very well. There are no boost leaks as boost is fine, maf is good O2 is good, but what i did notice was that when i took leads off while running the spark was jumping out of the side of the ignition pack that sits on top of the motor from 2 of the lead outles, so this leads me to believe that its a spark leak problem.

My question is are there any aftermarket ignition coils for this model that anyone can recommend to me as the local spare parts shop wants $400 -900 just for the coil, I have done abit or looking but as I dont have a manual or any really good specs on the engine i am a bit lost in this regard also its my first subie :(

Cheers in advance

Peter
 

·
Registered
02 Forester L (sold) Manual
Joined
·
1,220 Posts
They are known for occasional coil failures so I think you're on the right track. Can't help you with a replacement though as you are in NZ. Perhaps you could find one used at a breaker's?
 
1 - 2 of 2 Posts
Top