Subaru Forester Owners Forum banner

21 - 23 of 23 Posts

·
Premium Member
'09 STI
Joined
·
4,212 Posts
But why do our exhaust components always seem to be funny...I honestly don't get it..... :shrug: Virtually every Subaru community Forum have posts upon posts of such problems, even those who used brand new hardware (for some of my "Stage II" installs, new hardware was used, too - and there was no noticeable difference between whether or not it was re-used hardware that backed off [which would make sense] or new [which did not make sense]). Dunno. :shrug:
Most likely because most aftermarket exhausts are of crap quality and eliminate flex joints that came from the factory.
 

·
Registered
2007 FSTI and X 6 MT
Joined
·
22,342 Posts
We torqued to spec most of the bolts during the install. That is, the ones that we had enough room to fit the torque wrench on. The rest are just monkey tight.
Mine showed no visible soot on it either, and since I was not running a heat shield, I could look at it for answers either.
 

·
Registered
2016 Outback and WRX CVT
Joined
·
2,589 Posts
Most likely because most aftermarket exhausts are of crap quality and eliminate flex joints that came from the factory.
^ That's a good point.

I wonder if there's any poll of who used what -

- take-off/OEM components (i.e. STi-UP)
- design of aftermarket component (i.e. with/without flex or other stress-relief, brand names, etc.)
- new versus used parts
- new versus old/re-used hardware
 
21 - 23 of 23 Posts
Top