Subaru Forester Owners Forum banner

1 - 4 of 4 Posts

·
Registered
03 Forester
Joined
·
31 Posts
Discussion Starter #1 (Edited)
I recently blew the hg in my '03 X with 115k miles. It took a while to figure out; it had looked like a radiator or therm problem. So the car overheated a few times. Anyway, we finally had both head gaskets redone. The shop also replaced the O2 sensors, reset the computer, adjusted the throttle, everything that's normal to do with head gaskets.
It's a manual tranny and I drive like a granny. I used to get 25-26 mpg's. But immediately after the repair I'm getting 23-24.
I checked the pressure on my tires, ran some fuel system cleaner, and have tried some different gas. Everything (oil, filters, etc.) is up-to-date. Nothing's helping! The temperature has dropped from 70's to 40's. But it didn't happen at the same time as the hg and the mpg drop.
Did the overheating damage something? Any ideas?

Just FYI, it's been 1000 miles (four tanks of gas) since the HG repair and MPG decrease.
 

·
Official sf.org decal guy
2006 FXT
Joined
·
12,516 Posts
I recently blew the hg in my '03 X with 115k miles. It took a while to figure out; it had looked like a radiator or therm problem. So the car overheated a few times. Anyway, we finally had both head gaskets redone. The shop also replaced the O2 sensors, reset the computer, adjusted the throttle, everything that's normal to do with head gaskets.
It's a manual tranny and I drive like a granny. I used to get 25-26 mpg's. But immediately after the repair I'm getting 23-24.
I checked the pressure on my tires, ran some fuel system cleaner, and have tried some different gas. Everything (oil, filters, etc.) is up-to-date. Nothing's helping! The temperature has dropped from 70's to 40's. But it didn't happen at the same time as the hg and the mpg drop.
Did the overheating damage something? Any ideas?

Winter gas maybe? Also, with the assumed disconnection of the battery, there is likely a learning period for the ECU.
 

·
Premium Member
2015 OutBack Ltd
Joined
·
3,123 Posts
Hmmm....another HG???.....and on an SG?...................is someone keeping score on these?

I'll bet that winter gas is the culprit........my 03X has dropped a bit over that past weeks and I'm pretty sure that NH has made the switch to the crappy blends for the winter......

Steve
 
1 - 4 of 4 Posts
Top