Subaru Forester Owners Forum banner

1 - 7 of 7 Posts

·
Registered
1998 forester L automatic
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi I'm new to the forum and I just go my 1998 Subaru forester L. It runs good but after driving for a little wile it starts to have a miss fire. It will stop and start doing it randomley. Some times I will get a check engine light and it will blink sometimes. What would i be looking for? I will be doing the plugs soon and wires many oil in the spark plug tubes. Heads was done about 60 k ago
 

·
Registered
2004 Forester XT 4EAT
Joined
·
1,322 Posts
Hi,
Have you had the codes from CEL verified? I'd agree to do the plugs/wires and replace the spark plug gaskets/grommets as I've read about oil getting on the plugs.

Also were the valves adjusted when the 'heads was <sic> done about 60 k ago'? This is the Head GASKET correct?

If not you could have a tight valve and/or it could be burnt, which is neither easy nor cheap to fix.


GL,
TD
 

·
Registered
1998 forester L automatic
Joined
·
6 Posts
Discussion Starter · #3 ·
From what I was told there was new heads put on. Also I've noticed if I drive it a little bit then stop some where and leave it run for say 10 min. I will have a check engine light when I get back in. When I go out to start the car in the am no light. I can drive 120 miles and no light will come on highway that is.
 

·
Registered
2006 FXT 6MT
Joined
·
2,699 Posts
The CEL is entirely emissions based and is set off by whatever the car senses that may affect emissions. If it's blinking, you are risking or are damaging your cats, which is BAD.

The plugs/wires/valve cover gaskets and spark plug tube gaskets are all cheap and very easy. That's the most obvious first step in a misfire with these engines.

Second to getting the codes read, I suppose.
 

·
Premium Member
2008 Forester X Premium 5MT
Joined
·
8,064 Posts
Getting the code is a must before any advice can really be given.
 

·
Registered
00/4 Forester S, X Auto, Auto
Joined
·
318 Posts
If any codes pop up PO300, 301, 302, 303 or 304 You may need plugs & wires. Don't go cheap. Cheap will run cheap. Also look at the coil pack. I did a complete job on my SF and still had a misfire. Pressure at the injectors was fine so a shot in the dark I replaced the coil pack and problem solved.
 

·
Registered
1998 forester L automatic
Joined
·
6 Posts
Discussion Starter · #7 ·
Thanks guys. I tried to change the plugs yesterday but the rubber thing on the end of the old plug wire is stuck in the spark plug hole. I tried to remove it with no luck. I will try again today. But I did notice one of the plug wire ends was cracked so I changed it. I did find out that the reason the light came on when ideling for ten min. Was because the idle air control valve I changed it problem solved. With that issue
 
1 - 7 of 7 Posts
Top