Subaru Forester Owners Forum banner

1 - 9 of 9 Posts

·
Registered
2009 Forester Auto
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi guys

I tested out my 09 forester xt with a vf52 turbo. When i go full throttle at 60km/h or 70km/h in 2nd gear, the engine seems to be straining.The revs started climbing slowly. I couldnt feel much boosting going on too even as it climbed the revs.

What could be the problem?:icon_confused:
 

·
Registered
1999 Forester S Turbo 5MT
Joined
·
1,960 Posts
Did you get the map adjusted? If not, the ECU is likely pulling timing and boost, assuming the turbo and installation are all correct.
 

·
Registered
2011 turbotek tuned fxt 4eat paddle shift
Joined
·
3,539 Posts
Probably would be better if you give us a list of mods and tunes? Cant really tell you much on what your saying but probably a boost leak at your tb to intercooler hose.
 

·
Premium Member
2009 Fozzie XT Ltd 4EAT
Joined
·
553 Posts
you doing any data logging?
 

·
Registered
2009 Forester Auto
Joined
·
11 Posts
Discussion Starter · #6 · (Edited)
Probably would be better if you give us a list of mods and tunes? Cant really tell you much on what your saying but probably a boost leak at your tb to intercooler hose.
Mods:
1. Apexi CAI
2. Decatted stock exhaust
3. Walbro 255 fuel pump
4. Stock TMIC
5. Vf52 turbo
6. Used romraider + ecuflash to tune

I dont know if this will help: Occasionally, i will do a sudden hard acceleration and release the pedal right away, there will be a loud pop sound at the exhaust.
 

·
Registered
2012 XT Touring AT
Joined
·
1,841 Posts
that is an afterfire. unspent gas going into exhaust system. that could happen if you have a BPV that is venting too much instead of recircing the air back into the inlet


record a few pulls/logs with romraider and post them....
 

·
Registered
2009 Forester Auto
Joined
·
11 Posts
Discussion Starter · #9 ·
Need logs and how do you know you are not getting boost and who is tuning it?
Problem solved. It was the dirty Maf sensor that was causing the problem. Acceleration is less retarded now. However there is still the lag from the old 4spd autobox.
 
1 - 9 of 9 Posts
Top