Subaru Forester Owners Forum banner

1 - 8 of 8 Posts

·
Registered
1998 Forester
Joined
·
15 Posts
Discussion Starter #1
help... i have a 99 forester 2.0t a/t it has 90t km on it.. the problem right nos is every time i step on the gas it losses power or sometimes dies cant even get it to 1500 rpm now. it started a bout a month ago but was still tolerable. car tuns worse when temp is at normal. revs are good as long as there is no engine load. some times CEL is on but not all the time.(hard to find a shop here in the Philippines who does obd reading). when we did it no reading cant bring the car back to the shop its 2hrs away(it wont make it)

mods to the car
-exhaust
-bov
-dyno tuned
-greddy emanage
-sound system

things ive done
-tune up(change oil, sparkplug, filters)
-ran better for a day then back to lossing power
-reset (remove bat)
-checked fuel press(38psi)
-checked boost(10psi.)
-repalce fuel filter
-checked the gas
-checked sensors
-just mad sure its tight
-replaced batt
-checked turbine and intecooler
-checked all pipings and connections(no leaks)
*the car was running good when it was in the shop

things suggested to me
-replace fuel pump
-check/replace coil
-how??
help plssssssss........

by the way the car was converted rhd to lhd and i dont know much about technical terms and subarus(my 1st) but i do my own mechanics..

:confused:
 

·
Registered
04 Forester X, MT
Joined
·
1,039 Posts
I have a 2.5 NA.

First thing is to get the codes read to really know what is going on. Consider getting a code reader yourself if at all possible.

The CEL is likely either misfire or some bad sensor.

I owned 2 different '00s and had to replace knock sensor and crank sensor. Both produced intermittent CELs and driveability issues. I think driveability was worse with the bad knock sensor.

I would replace the plug wires before I would replace the coil.
 

·
Registered
1998 Forester
Joined
·
15 Posts
Discussion Starter #3
i wont be able to get an obd reader here... and i dont know any one with a trailer my car really wont go...

im checking the wires, plugs again it..

where can i fid the knock sensor and other sensors.?

thanks..
 

·
Registered
1998 Forester
Joined
·
15 Posts
Discussion Starter #5
got everything good so far hope its going to be for good... removed the sensor behind the turbine and infront of the catalytic converter and cleaned the ignition coil(i think)...
 

·
Registered
1998 Forester
Joined
·
15 Posts
Discussion Starter #6
took the car for a drive its better

except for sudden drop of power(with wierd sound) when in high rpm for a while and then the hold button starts to blink no CEL. and a after i stop for a light it starts to stall again but for only a short time not like befor

help pls....
 

·
Registered
1998 Forester
Joined
·
15 Posts
Discussion Starter #8
good day noticed something new again...

when i parked in an open parking space and it was extremly hot outside the it started to stall bigtime again but after driving a few meters, and few engine dies and restart it ran better..

help plssss...
 
1 - 8 of 8 Posts
Top