Subaru Forester Owners Forum banner
1 - 3 of 3 Posts

·
Registered
2004 Forester
Joined
·
39 Posts
Discussion Starter · #1 ·
04 FXT with 180Kms running rough getting some knock and Cyl 4 and getting P0340: Camshaft Position Sensor code every few days. Looking into injectors and rechecking plugs and coils on cyl2 and 4 today. 2 questions for now #1: Injectors were removed by a shop few years back and now i notice 3/4 are missing the grey caps, is that a problem and what are they for?
#2 Not confident there is a problem with them but they are 15 years old and never been assessed/cleaned so not willing to buy new ones yet, SO... is the a way to clean the side feed injectors like you can easily clean top to bottom injectors IE syringe with break cleaner and pulsing with a 9v battery? Thanks for any info or links!!!
 

·
Registered
2004 Forester
Joined
·
39 Posts
Discussion Starter · #2 ·
Update! Just pulled Cyl 4s plug and it looks like slight oil on it and I think I was loose always scared to damage the threads!, what do you guys think? It was replaced 6 months ago but only 10,000Ks since. Too dark and cold now will get cyl 2 plug in the morning and compare.
 

Attachments

·
Registered
2004 Forester XT
Joined
·
63 Posts
If I recall correctly 0340 should be the passenger side camshaft sensor. That is cylinders 1 and 3. 0341 should be drivers side, cylinders 2 and 4.

Why did the shop have to pull the injectors?

They could have very easily dislodged a cam shaft sensor connector since they are right next to each other. And, over time the connector could have wiggled loose.

Either way, your injectors should have been replaced by now. Your major maintenance interval has passed, so it is due for timing components, valve check, compression and leak down checks too.
 
1 - 3 of 3 Posts
Top