Subaru Forester Owners Forum banner

1 - 4 of 4 Posts

·
Registered
1998
Joined
·
50 Posts
Discussion Starter #1
As a family, we've had many Subarus with keyless entry, but none have had the Code Alarm system from the late 90's. I've just installed module on my 98 Foz, and it works. It just does a few strange things that concern me. I'm not certain if this is how the unit is supposed to function, or if mine is glitchy (purchased via online salvage.)

First, when I unlock the doors both the overhead light AND the dash/door-open lamp turn on. Obviously, there are no doors open yet, so I found this odd. I understand the overhead light completely, it's the dash light that's got me confused.

Also, after driving, when I switch off the ignition, the same thing happens. Instant overhead light (which didn't used to happen until the door was open) and dash/door-open lamp come on. In this instance, these lights stay on until I use the FOB to lock the doors. If I manually lock them (routine habit after 3 years), the lights still stay on.

So basically, is this normal operation? Anyone??
 

·
The Modfather
2019 Impreza 5dr Sport - Manual
Joined
·
8,054 Posts
Yes my 99 RS did that, AFAIK it's normal. When installing the alarm there is a dome light loop plug you need to remove, it makes it think the door is open when you turn the alarm. I believe the alarm uses the door pins to set the alarm off.

install manual here:

http://www.scoobymods.com/impreza-alarm-t82.html?t=82
 

·
Registered
1998
Joined
·
50 Posts
Discussion Starter #3
Well, I don't have the security system add-on, but this info does help ease my worries. The unit is working well, now that I have the right fobs. I bought a set off ebay after I got the module. (I looked for over a year for one!) They were remote starter fobs, not keyless entry. :icon_frown: Due to RL drama, I wasn't able to return then within the allotted time frame. It burns me that the seller is still listing them as keyless entry when I told him they didn't work. :icon_mad:
 

·
Registered
2001 FORESTER 2L S TURBO
Joined
·
1 Posts
i have a problem with my immobilizer. it sometimes wont let me start. is there anyway you can disconnect it or bypass it .
 
1 - 4 of 4 Posts
Top