Subaru Forester Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey so I just gave my intro in the new members area, so I thought I'm just going to dive right in here. So at idle my 99 forester will idle normal then 10 seconds later drop rpms and barely run then 10 sec later return to normal. Any ideas where to start? It does have a cheapie intake on it which I'm thinking might be the culprit. As well as a full exhaust system. No check engine lights on, but who's to say the light hasn't been taken out
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
39,507 Posts
@Cheeney I'm not sure this will help, but it doesn't cost anything to give it a try. :wink:

How to Idle Re-Learn after Battery Disconnect

Also...
For the best forum experience, we recommend completing your "Public Profile". Specifically, the "About Me" section (Edit Your Details). This displays every time you make a post on the forum. This will provide information members may need to reply to your forum posts. You can edit this field via the "User Control Panel", aka, "User CP.

If you're using a mobile device, you may need to use a laptop or desktop computer to see all the user tools.
Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

·
Registered
MY05 Forester 2.5 XT 5MT
Joined
·
2,817 Posts
Clean the Idle Control Valve?
Does the throttle open and close smoothly by hand?
Any air leaks in the intake system?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I will look at it tomorrow I just got the car and jaunt done anything with it yet but il try the idle relearn and try to clean idle valve

Well idk if it's part of the issue but ran my code reader and it came up with knock sensor which would explain the hesitation and hard start and dead spot in throttle. Possibly it retarded timing enough where idle is off?
 
1 - 4 of 4 Posts
Top