Subaru Forester Owners Forum banner

1 - 5 of 5 Posts

·
Registered
1998 Forester S Manual
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey everyone. So as the title says, my highbeam dash indicator light is half way illuminated when the headlights are on (low beam). When the highbeams go on, the light is noticeably brighter than it used to be. Problem started about a month ago, and I used to be able to flip the highbeams on and off and the light would go away. But now its always on when the headlights are on.

Since it started, ive cleaned and packed all the accessible wiring connectors, and have done a couple ECU resets. No change.

Sort of seems like a short, but the actual indicator still works so im not too sure. If something was shorting it would be completely lit up all the time, correct?

Any ideas on where to start?
 

·
Registered
2000 Forester S Turbo Manual
Joined
·
932 Posts
Does your check engine light come on when you start up?
Saw something on the net once, where a dealer couldn't clear a code, so re-wired the bulb to something else.
Its probably not that, but best to pull the cluster out anyway, to check, if the above doesn't fix it.
Guide here: NorthUrsalia.com: Painted Dash Cluster Face
 

·
Registered
1998 Forester S Manual
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks for the replys, I noticed that the passenger headlight connector cuts out if I wiggled it. I replaced the connector and everything works great. No more indicator as well. Thanks!
 

·
Administrator
2016 & 2018 2.5i Premium CVT
Joined
·
19,347 Posts
Informed wiggling is an important skill. Well done.
 
1 - 5 of 5 Posts
Top