Subaru Forester Owners Forum banner
1 - 15 of 15 Posts

·
Registered
2006 2.5XT 5 SP Man
Joined
·
1,012 Posts
Discussion Starter · #1 ·
Hi guys

I now have 2 foresters, and both surge/hesitate quite bad

my 2006 pre facelift 2.5XT is in the garage at the moment with a mate ,

cruising is absolutely fine with no issues, however if you are accelerating at a steady pace and sometimes at full throttle it doesn't seem to want to pick up

there are no codes and the MAF seems to be reading fine. no missfires and I am getting 30 MPG.

I am changing the plugs tomorrow incase the gaps are out.

anything else anybody has experienced??

both of my cars do it now, the S turbo has been diagnosed as the MAF but this one im unsure
 

·
Registered
2006 Forester XT Limited 5MT
Joined
·
230 Posts
Hi guys

I now have 2 foresters, and both surge/hesitate quite bad

my 2006 pre facelift 2.5XT is in the garage at the moment with a mate ,

cruising is absolutely fine with no issues, however if you are accelerating at a steady pace and sometimes at full throttle it doesn't seem to want to pick up

there are no codes and the MAF seems to be reading fine. no missfires and I am getting 30 MPG.

I am changing the plugs tomorrow incase the gaps are out.

anything else anybody has experienced??

both of my cars do it now, the S turbo has been diagnosed as the MAF but this one im unsure
Im dealing with this right now...
Tuner is trying to tune it out, after I had a TMIC boost leak fixed...

Started after I had disconnected the battery.

I read so many threads Im hoping it will be a simple fix...
P
 

·
Registered
2006 2.5XT 5 SP Man
Joined
·
1,012 Posts
Discussion Starter · #5 ·
I do 180 miles per day commute mostly at 50-75 mph. Got 28 first tank, 30 second tank.

I change gear at 3000 revs.

Changed the plugs today. Clean boost solenoid and manifold pressure sensor. When i took out the coil packs the bolts holding them in were very corroded. Cleaned them up while they were out as I think they earth the units out.
Hesitation seems to have gone but will confirm tomorrow
 

·
Registered
2004 Forester XT 5MT
Joined
·
511 Posts
I am having this issue now. I had a hesitation on my 04 XT, usually at partial throttle around 2,600 rpm. So, I changed the oil (Rotella T6 5w40) changed the plugs (NGK iridium 1 step colder) and did the evap purge valve delete mod (ok, ok, ok I broke a nipple on the purge valve at 1830 on Christmas Eve)

Now I have a horrible issue when i start to build boost. It literally feel like the car is over boosting. No CEL, no other issues. It pulls HARD and then just hiccups and loses all power for a quick second. If you stay on it, it stutters. Runs, idles and drives out of boost like its a brand new car.

Any suggestions?
 

·
Registered
2006 2.5XT 5 SP Man
Joined
·
1,012 Posts
Discussion Starter · #9 ·
Hi guys,

Defo not the oil as it's been changed twice and it's defo not overfilled

Just changed the MAF and it's a lot better but still stutters on idle so will be changing two coil packs on one side , then swap them or buy two more if it persists.

The car is still not 100% but it's getting there, no codes on ecu and no engine light .

What is this valve delete thin your doing?
 

·
Registered
04 forester xt
Joined
·
969 Posts
If you have a tantric cable get a maf tab and see what kind of corrections it's making. Phatron of phatbotti etuning can scale your maf and give u a good tune, all opensource. I had this same problem and this helped big time, even after the dynotune I was running. Disconnecting the battery,it will go away for a lil bit and return after the ecu learns


Sent from AutoGuide.com Free App
 

·
Registered
2002 2.0l
Joined
·
14 Posts
Surely Subaru has a solution??

I've had two Forester XT autos, both of which suffer(ed) from this "hunting" under load.
It's embarrassing to pass someone up a hill - I go past in leaps and bounds, he must think I'm sloshed!
It's the same whether I'm in cruise control or manual throttle.
It's so irritating when there's an obvious and common problem with a vehicle and the manufacturers and agents pretend they've never heard of it!
This annoying defect has contributed to my moving to Mitsubishi after 12 years of Subaru motoring.
 

·
Registered
2006 2.5XT 5 SP Man
Joined
·
1,012 Posts
Discussion Starter · #15 ·
Hi guys

thought I would keep you updated.

I had my cambelt done yesterday (80k miles with no history of previous belt change)

the cambelt had been changed with a "gates" one, however whoever fitted it had done so incorrectly and the timing was out!!!!!

it now runs 1000% better with only slight hesitation and so I will be changing the coil packs next a the MAF is brand new.

Jim
 
1 - 15 of 15 Posts
Top