Subaru Forester Owners Forum banner

1 - 2 of 2 Posts

·
Registered
2005 Forestor XT2.5
Joined
·
2 Posts
Discussion Starter #1 (Edited by Moderator)
I have 2005 XT2.5 and yesterday in slow traffic in the morning and afternoon my SF was smoking like you cannot believe. I lost 1L of oil and had to top up this morning. The strange thing is it does not smoke on start up nor while driving. Today I drove to work, no smoke.Left it idling for 10 min and no smoke?? I have had the turbo done (twice) by the dealer 3 months ago when it had this problem. Is it the turbo again ??? Is this poor workmanship or it there something else that is the root cause? I am deperate for some one to give me the actual fault and not have to spent more money then needed. The dealer wants to strip my engine to check it and I dont want that without ruling out the turbo, pcv or something else???!

Can any one advise what I should do?
 

·
Registered
07 FXT sport
Joined
·
1,743 Posts
Need some more information.

Can you see where the smoke is coming from. Get it to the point of smoking and then pull over and inspect the information.

Are you sure it's oil?? You said that you lost 1 liter of oil, are you sure you just haven't lost oil over time??

Can you smell the smoke?? Does is smell like oil or coolant??

When you look at the engine do you see any locations that have heavy oil leakage on them, valve covers leaking, etc...

Good Luck.

I know that I don't have any answers, just trying to get more information to help you track down your problem.

dm
 
1 - 2 of 2 Posts
Top