Subaru Forester Owners Forum banner

1 - 8 of 8 Posts

·
Registered
1999 Forester S
Joined
·
28 Posts
Discussion Starter #1
99 foz. ive been hearing up go through the back seat like a bmw e30, remove butt cushion and carpet, remove cover above pump and instant access.
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
39,502 Posts
From my quick look at the technical manual, it appears to be same as for my '03 X or my '07 FSXT. Take a look at my write ups here & here. There will be differences, but this should give you an idea of what to expect. :wink:

Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

·
Registered
1999 Forester S
Joined
·
28 Posts
Discussion Starter #4
ive shoulda asked before, but what are the ratings (gph/psi) on the NA 2.5? would putting say the walbro gss342 pump in with a new fpr change anything fuel consumption wise?
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
39,502 Posts
Adding a fuel pump with more flow won't increase your fuel consumption. The fuel pump can provide more fuel, if your engine needs it. :smile:

Curious... why are you going to change the fuel pump? :confused:

Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

·
Registered
1999 Forester S
Joined
·
28 Posts
Discussion Starter #6
ive been having this hesitation during accel and even at cruising speeds (just started) since i got my car back from the mechanics for the head gaskets. ive done a tune up (plugs wires coil pack fuel filter fpr) and its still there and getting worse as each day goes by. ive had a computer hooked up to watch the instant views and the o2s are sending good numbers, the tps is sending decent numbers (just alil off) and the map has good readings the timing is dead on. im getting frustrated and swapping parts now. by god, if this doesnt solve the problem, im taking it to the boonies and im having a bonfire.
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
39,502 Posts
When the front O2 sensor was starting to fail on the '03 X, I would get hesitation when starting off from a stop. I'd get backfires & the exhaust tip was overly sooty. I got a CEL code, but it was a P0420, which was the CAT being overwhelmed by the front O2 sensor running the engine too rich. Replacing the front O2 sensor cleared the problem. :smile:

I'm not saying this is your problem, just what I experienced with the '03 X. :wink:

Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

·
Registered
1999 Forester S
Joined
·
28 Posts
Discussion Starter #8
the o2s are sending good signals but those will be replaced here in about 3 or so weeks just cause i can. cleaned everything electrical that involved the fuel system and timing. replaced easily accessible things dealing with fuel delivery (filter and fpr) and it helped for a day, until it started acting up again. but if it helps anymore, the only time it really starts to act up is when its above 85 degrees. in a way, its alot like the symptoms of vapor lock
 
1 - 8 of 8 Posts
Top