Subaru Forester Owners Forum banner

1 - 13 of 13 Posts

·
Registered
1999 forester
Joined
·
36 Posts
Discussion Starter #1
My cel came on the other day and it threw the code p0452 at me. I'm assuming its either the fuel pressure sensor or my fuel pump. Has anyone come across this problem before?
 

·
Registered
none none
Joined
·
8,844 Posts
"P0452 Evaporative emission control system pressure sensor low input"

It has to do with the fuel tank pressure. Its most likely a loose gas cap, faulty gas cap, or rusty fuel filler tube.
 

·
Premium Member
2014 Impreza Ltd CVT
Joined
·
3,319 Posts
P0452 means the sensor output is low .... meaning the sensor is defective ( open ) OR you have a broken wire/bad connection between the ECU and the sensor in the tank.

This error does not point to the actual pressure in the tank being low. but the circuit from the ECU to the Pressure sensor and the return back to the ECU.
 

·
Premium Member
2014 Impreza Ltd CVT
Joined
·
3,319 Posts
so if the output is low could it be the sensor itself?
Yes as I stated above, the sensor or any wiring or connectors back to the ECU can cause this code.
 

·
Registered
1999 forester
Joined
·
36 Posts
Discussion Starter #7
so i went to auto zone and they gave me a read out of what it could be and it said that it could be the evap sensor. is that the same as the fuel tank pressure sensnor? and where is it located?
 

·
Registered
none none
Joined
·
8,844 Posts
The sensor, if I'm looking at this correctly is about in the middle of the top of the fuel tank. Looks like you may have to drop the tank to get to it.
 

·
Registered
03X MT
Joined
·
846 Posts
pretty sure that there is access to the tank by taking out the back seat. At least that is how access is gained to replace the fuel pump/ filter.
 

·
Registered
1999 forester
Joined
·
36 Posts
Discussion Starter #10
i know its within 6 inches of the pump. im hoping theres an access panel. haha. im gonna attempt it wednesday.
 

·
Premium Member
2014 Impreza Ltd CVT
Joined
·
3,319 Posts
Here's the pdf for the 99-02 ..... looks like it IS between the access holes and they say the tank has to be removed.
 

Attachments

·
Registered
1999 forester
Joined
·
36 Posts
Discussion Starter #13
alright. so i pulled a sensor from a junk car today for 10 instead of 400.... but its nasty as hell in spokane so im wainting till tomorrow to put it in. any advice?
 
1 - 13 of 13 Posts
Top