Subaru Forester Owners Forum banner
1 - 20 of 28 Posts

·
Registered
2000 Forester STI
Joined
·
134 Posts
Discussion Starter · #1 ·
Hey guys, I have a serius problem. I have a 2001 subaru forester A/T (JDM).

The problem I am having is when I drive the car normal with out flooring the pedal the car shift normal, if however when I floor the pedal the car stutter and then shift.....there is no code on my dash. It feels like the fuel is cut just as the car shifys or some thing. I would really like some assistance with this issue
 

·
aka DMax in Alaska
'06 Mini Cooper S JCW 6MT
Joined
·
786 Posts
Not sure what the issue is but perhaps try manually shifting while flooring it and see if it happens then too. Maybe it will help to pin it down to Fuel Cut.
 

·
Registered
2000 Forester STI
Joined
·
134 Posts
Discussion Starter · #3 ·
If I shift manually the cars shift without any issues...... no stuttering ........ when I put it in drive then that's where the problem is. you get that stuuter sound just when it shifts
 

·
Registered
2000 Forester STI
Joined
·
134 Posts
Discussion Starter · #4 ·
if I don't floor the pedal the car builds power and shift properly, only when I floor the pedal aroud 6,000 just before it shift you hear that stuttering sould like the fuel is cut at that time........I am going to try a nw MAF tomorrow and see if that helps
 

·
Registered
99 UK S-turbo
Joined
·
8,566 Posts
Not sure what you mean here, is the stutter in the engine not increasing power cleanly or in the transmission not shifting cleanly?

Simon
 

·
Registered
2000 Forester STI
Joined
·
134 Posts
Discussion Starter · #8 ·
things done so far.

1. ECU changed (same problem)
2. Plugs changed(same problem)
3. MAP changed (same problem)
4. MAF changed (same problem)
5.Igniter coil changed( same problem)
6. Injectors changed(same problem)
7.Current rewiring my harness as it was cut to install a full management. I remove the managemnet now the car is stock. Hoping after the harness rewiring the problem will go away. Again any help is most welcomed
 

·
Registered
99 UK S-turbo
Joined
·
8,566 Posts
What management was fitted? No aftermarket management that I am aware of is compatable with the TCU and will lead to problems, the importance of telling us the whole story from the start!

Simon
 

·
Registered
2000 Forester STI
Joined
·
134 Posts
Discussion Starter · #10 ·
I fitted a E6x haltech......... it destroyed 3 transmission before the tuner realise it can't work with the automatic tranny. I removed the management and I now have the car stock, but as mentioned when the car reaches about 6-7000 rpm sometimes earlier it breaks up a kind of stuttering at the higher rpm then it shifts. This only happen when I floor the pedal, normal drinving the car dosent break up at the lower RPM.I think it have something to do with the fuel injection wiring and the grouding of some sort. That is the whole story. thanks again
 

·
Registered
99 UK S-turbo
Joined
·
8,566 Posts
Seeing as how we have no idea now what has been done to the car its almost impossible to diagnose via vagueish descriptions.....

To be clear what exact spec is your car, you say JDM, so I assume STB or TTB? Not sure what rpm they usually upshift at, I wonder if its a rev limiter issue casued by a delayed upshift perhaps due to the incompitant messing?

Simon
 

·
Registered
2000 Forester STI
Joined
·
134 Posts
Discussion Starter · #14 ·
Ok it's a JDM SF5 STI spec..... I would try to be very clear......I fitted a Haltech E6X full management........ It destroyed 3 transmission. I now removed the E6X and have the car stock....No mods. The problem am having is when I accelerate sharly the car give a stutter just around 6-7000 rpm before it shifts........ it feels like the fuel is being cut, or the ignition restarding.... this only happen at sharp acceleration, if i drive the car normal meaning dosen't go up to that high rpm it shifts normal with no issue.

I did some research on hesistation and did some other checks

1. e check the O2 sensor and it seems find, we currently looking into the nock sensor scenario. I know the harness mas rejioned because the Haltech controlled the fuel, shared the TPS and shared some other signal. I hope this helps, am just about thinking to live with that problem
 

·
Registered
99 UK S-turbo
Joined
·
8,566 Posts
AIUI (and this is from sources on here) the STi has a different 4EAT to other Foz/Impreza, so have you got an STi trans or a non STI one, if its non STI and the TCU is still STi that may be the problem, sounds to me like its clipping the rev limiter, this cuts in at 7000rpm, but bear in mind the EJ20 engine accelerates faster than the rev counter can follow (in first mine hits the rev limiter while it still says 5500rpm!), so just because the needle isn't at 7000, doesn't mean the engine isn't.

Simon
 

·
Registered
none none
Joined
·
8,844 Posts
AIUI (and this is from sources on here) the STi has a different 4EAT to other Foz/Impreza, so have you got an STi trans or a non STI one, if its non STI and the TCU is still STi that may be the problem, sounds to me like its clipping the rev limiter, this cuts in at 7000rpm, but bear in mind the EJ20 engine accelerates faster than the rev counter can follow (in first mine hits the rev limiter while it still says 5500rpm!), so just because the needle isn't at 7000, doesn't mean the engine isn't.

Simon
Even on a stock XT with the 6.5k rev limit it sometimes clips the rev limiter if you go WOT while already at too high of an RPM in a gear. The shift ends up taking longer than the amount of time the tcu figured it would take to hit redline or something.
 

·
Registered
2000 Forester STI
Joined
·
134 Posts
Discussion Starter · #18 ·
Ok am current having the wiring looked at, If the sensor is fooling in the transmission would it give a code, As mention am getting no code. What I notice if I have the car in #1 and pull of the car shifts to # 2 as though it still in drive, that suppose to work like that? again thanks for the assistance
 
1 - 20 of 28 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top