Subaru Forester Owners Forum banner

1 - 12 of 12 Posts

·
Registered
2010 Forester XT Auto
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,

I'm a member of a few forums and know this is big no-no as a first post but I promised I searched! :icon_redface:

I need to replace the front o2 sensor but need some guidance on where the connector is before I start taking things apart. I have an XT, looks like it's somewhere under the air box? Can someone confirm?

TIA, look forward to being a member here!
 

·
Registered
Joined
·
39 Posts
Hi There,
Just wondering how the change out went? I am trying to diagnose some Check Engine codes, and some paths are leading me to think my O2 sensor may need changing.

I also have a 2010 XT.

Would you mind telling me how difficult the job was?

Thanks!
Mike M
 

·
Registered
2010 XT Limited 4EAT
Joined
·
1,447 Posts
Hi There,
Just wondering how the change out went? I am trying to diagnose some Check Engine codes, and some paths are leading me to think my O2 sensor may need changing.

I also have a 2010 XT.

Would you mind telling me how difficult the job was?

Thanks!
Mike M
Doesn't look too bad :)
 

Attachments

·
Premium Member
2011 XT Touring 4EAT
Joined
·
12,185 Posts
Hi There,
Just wondering how the change out went? I am trying to diagnose some Check Engine codes, and some paths are leading me to think my O2 sensor may need changing.

I also have a 2010 XT.

Would you mind telling me how difficult the job was?

Thanks!
Mike M
what codes are you getting? is it def for the front sensor? i only ask as i had a faulty rear sensor while back...which blew my CEL.

for the front....while i havent done it myself...if you poke your head under the front passenger side of the engine...its hanging right there in front of you. theres heat shields so you may need one of those o2 sensor sockets (with the open "side" for the harness) but not 100%.
 

·
Registered
Joined
·
39 Posts
Hi,
I am now getting 171, as well as all 4 misfires P0301-P0304

The dealer is suggesting they do a smoke test to look for vacuum leaks.

Thanks!
Mike
 

·
Premium Member
2011 XT Touring 4EAT
Joined
·
12,185 Posts
a popular thread on nasioc on that code in particular does mention the upstream o2 iirc. so you may be right. none of my codes were misfire related...so my downstream sensor story wont help you.

since its a fairly important sensor, it wouldnt hurt to swap it with a known good one if possible. or just make that change #1 and see what happens. @AlbertaCanadaMike
 

·
Registered
2010 Forester XT 4EAT
Joined
·
12 Posts
Just Did a downpipe and up pipe swap on my 2010 sh had to unplug front 02 sensor from headers and remove o2 sensor from old downpipe for new one....
1. you need to remove the plastic splash shield from underneath the motor (3 bolts underneath and a subaru pop clip in either wheel well.
2. Get under car passenger front passenger side, Front O2 sensor connection is on engine block between wheel well, long #1 flat head to unclip on cabin side of plug
3. four (4) bolts off of passenger header heat shield.
4. Its location is B on Mattybigs PDF that he attached.
 

·
Registered
2012 XT Touring 4EAT
Joined
·
3,751 Posts
HTML:
That's where it should be. Mine is a bright blue. You can't miss it.
Right. The connector is on the passenger side wheel well, towards the rear of the engine compartment, in the area were the DRI resistor is located. It's bright blue (don't think any other connectors in this area are this color).

If you know the Denso model number, you may be able to find a genuine Denso unit on eBay for about half of what the dealer charges.
 
1 - 12 of 12 Posts
Top