Subaru Forester Owners Forum banner
1 - 10 of 10 Posts

· Registered
06 XS MT
Joined
·
13 Posts
Discussion Starter · #1 ·
Hello everyone, I looking for a bit of help tracking down the culprit of “small EVAP leak” code that I keep getting. Here is a list of what I’ve done so far:

- Changed fuel cap
- Changed fuel filler neck
- Confirmed operation of purge vavle
- Had a smoke test done (no leaks found)

At this point I’m running out of ideas and can’t just keep throwing money at this code by replacing random parts, does anyone have any suggestions of where to go from here? A couple of ideas I have left are:

- Take it to another shop for a smoke test and hope they find it
- The vent solenoid isn’t working (I can’t seem to find it on my car? Does anyone know where it is? I don’t hear clicking by the charcoal canister when the car is in test mode)
- Purchase an OEM gas cap since I just have a generic one
- Gas tank pressure test


Thanks for your time!
 

· Registered
06 XS MT
Joined
·
13 Posts
Discussion Starter · #3 ·
Honestly if it wasn’t for the loss of cruise control I’d just deal with it. Going to get a vacuum pump and see if I can narrow down the leak.
 

· Registered
06 XS MT
Joined
·
13 Posts
Discussion Starter · #6 ·
Alright guys help me out here. So I spent a couple hours getting to know the EVAP system and taking off the charcoal canister. I believe the 2006 has a vent valve built into the canister correct? Can anyone tell me how I can bench test this? I don’t wanna be replacing the 300$ canister on a whim here since it holds vacuum just fine.

Also I discovered another solenoid above the canister, I believe this is just a pressure control and the cable feeding into it is just to send information as there’s no mechanical valve inside?

Finally is it possible to buy just the vent valve and put it into the canister?

I’ll grab some pictures of everything tomorrow morning.

Thanks!
 

· Registered
06 XS MT
Joined
·
13 Posts
Discussion Starter · #7 ·


Alright guys, anyone got information on how to bench test part 9? What should it be doing? Is there a valve that should open/close when in test mode?
 

· Registered
06 XS MT
Joined
·
13 Posts
Discussion Starter · #16 ·
The CEL only comes on after the ECU runs two EVAP systems test and they fail. For it to run them there are specific conditions that need to be met that are usually favourbale to highway driving so that’s why you’re seeing the CEL only come on when on the freeway.

Anyone have experience changing out the vent valve inside the canister? It’s pretty easy to get at but I don’t understand how it works or where to get a replacement.

Maybe some more seafoam for now...
 

· Registered
06 XS MT
Joined
·
13 Posts
Discussion Starter · #18 ·
I may have gotten somewhere. I took the purge control valve off and it appears the bottom “outlet” will hold 21 in/mg of vacuum but the top “outlet” slowly leaks out vacuum pressure. Is this normal? I’m assuming not.
 

· Registered
06 XS MT
Joined
·
13 Posts
Discussion Starter · #20 ·
I replaced the valve, now I’m getting a P0549 Canister Purge Valve High Voltage code now. Any idea how to troubleshoot? I’m thinking it’s a short somewhere.
 
1 - 10 of 10 Posts
Top