Subaru Forester Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2010 Forester automatic
Joined
·
2 Posts
Discussion Starter #1
I have a 2010 Forester. All of a sudden the engine is running very rough, need to keep giving it gas to keep it from killing. Also noticed the engine light just came on at the same time.
 

·
Registered
2010 Forester 5-speed manual
Joined
·
169 Posts
My first thought is to look for any cracked or dislocated hose connected to the intake manifold or any loose connection of the intake manifold system somewhere between the throttle plate and the cylinder head. Since you have an automatic, does this happen in Park, Neutral, or Drive?

The check engine light may indicate the reason for the rough idle, but it can also be a result of the rough idle.
 

·
Registered
MY05 Forester 2.5 XT 5MT
Joined
·
2,752 Posts
Any smoke out the exhaust?
How is the fuel economy?
How is the oil level and any signs of mayonnaise under the oil cap?

Pop to your local Autozone/Autoparts store to get the codes read for free.

How is it for starting from cold?
How is it starting from warm?
Does it rev freely through the rev range in neutral? Same for drive
What's your mileage? Have the fuel injectors ever been cleaned?
Has the intake/throttle body ever been cleaned?
I would be checking for air leaks in intake hoses too.
You could consider cleaning the MAF sensor with the appropriate MAF cleaner only (Don't use brake cleaner)
Is your front oxygen (Upstream) sensor original?
Changed the fuel filter in the last couple years/ Last 20K miles?
 
1 - 5 of 5 Posts
Top