Subaru Forester Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2005 2.5 XTE
Joined
·
59 Posts
Discussion Starter #1
Recently had a code read by my diagnostic tool : P2432 Secondary air system. The short term fuel trim was 0, long term fuel trim -0.79 After a bit of googling it would seem the engine is running rich.
Things to check in order:

Spilit hoses
O2 sensors
MAF
SAI pressure sensors

have I covered everything? Have swapped over to Optimax, could this make the engine run richer or exacerbate the problem?

Mass airflow readings 12.22g @17.64% throttle engine speed 3687rpm

cheeers nuts
 

·
Registered
2005 XTEn Auto
Joined
·
1,139 Posts
Secondary air system is only used briefly at cold start up, so won't affect normal running.

From Don's kind information
P2432 Secondary Air Injection System Air
Flow /Pressure Sensor Circuit Low.

Is the air pump running.

Also see

http://www.subaruforester.org/vbulletin/f75/secondary-air-injection-67750/

Max.

Ps to make things easier could you post year and model.
 

·
Registered
2005 2.5 XTE
Joined
·
59 Posts
Discussion Starter #3
Its 2.5 XT on a 55 plate.

Funny you should say 'cold start system'. previously on a cold start I thought it was idling normally although a little low, never lumpy or cut out. After I had reset the code, the engine yesterday on cold start idled a lot higher after a few seconds around 1500 rpm. Same again today. However I would say that the fuel consumption is up slightly. The code has not come back either. Will have a listen for the pump tomorrow.

cheers nuts
 

·
Registered
2005 XTEn Auto
Joined
·
1,139 Posts
Secondary air only puts air into the exhaust before the cat when the mixture is rich. Don't think it would affect the running of the engine. I did read a post about removing the system all together and that just involved blanking off the exhaust flanges. It didn't alter the emisions readings in any way.

Do a search for P1410, that is the more common error code.

Max.
 
1 - 5 of 5 Posts
Top