Subaru Forester Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I went to have my emissions done today at the Subi dealer as I was there for an oil change, they said that the emissions computer cannot talk with the computer in my car?? So technically I failed I have a 04 XT with the STI Catback and all cats still in place, would this be a reason as to why they couldnt communicate? Also if I take it to a gas station do they use the same type of equipment or just put the tube over the exhaust?

Any info would be appreciated
 

·
Administrator
2004 Forester XT Premium 4EAT
Joined
·
29,450 Posts
A catback alone has no effect on emissions. Do you have a reflashed ECU?
 

·
Premium Member
2004 Forester XT
Joined
·
815 Posts
If you have reset your ECU, or had the battery disconnected in the past week or few days, your sensors may not all be reset. I had the same problem, and since all my sensors had not reset the emmissions equipment could "not communicate with ECU".


Solution? Drive around a few more days and the onboard diagnostics will eventually reset all sensors through several drive cycles.
 

·
Registered
Joined
·
1,310 Posts
If you reset your ecu on the car recently it would give the same result. It takes a bit for you ecu to get the signals from the exhaust probes to say everything is working good.

This is just what I heard.

Bland...
 

·
Premium Member
2012 GTI DSG 6-speed
Joined
·
1,463 Posts
Patcho said:
So technically I failed
Are you sure? In PA we have emissions testing as well. The station that I went to was unable to get there machine to connect to the ECU- but I still passed.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
I reset the ECU when I initially installed the catback which was over a year ago, maybe the fact that they did this after the oil change may be a reason, not sure if they check system out during this regular maintenance that would reset the ECU?
 

·
Premium Member
2017 Forester XT touring CVT
Joined
·
981 Posts
The catback would cause no issues like this. I passed this year and had the STI catback on my XT. Now last year I went in for inspection and the shop had the same problem you had. Their computer wasn't reading my car. They never could get a reading so they gave up and just passed my car assuming it was a problem with their pc. I had not done a thing to my car as far as mods or had I disconnected the battery. In fact, I was 2 months shy of having my XT a year so I have no clue what caused it. Now I have had it for 2 years and I don't know if they had the same trouble this year or not but they passed me.
 

·
MY BBEAST
2016 SUBARU FORESTER 2.5i AUTO-MATIC
Joined
·
714 Posts
Tell the dealership to program their computer to your car's language.....Spanglish.....lol
Patcho said:
I went to have my emissions done today at the Subi dealer as I was there for an oil change, they said that the emissions computer cannot talk with the computer in my car?? So technically I failed I have a 04 XT with the STI Catback and all cats still in place, would this be a reason as to why they couldnt communicate? Also if I take it to a gas station do they use the same type of equipment or just put the tube over the exhaust?

Any info would be appreciated
 
1 - 9 of 9 Posts
Top