Subaru Forester Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2004 Forester XT Auto Automatic
Joined
·
9 Posts
Discussion Starter #1
Hey all I currently have 2 engine swapped forester XTs. Both are swapped to EJ20X, one runs fine and the other has a bazar issue but let me explain the entire process to help give some context. Any advice on where I can check to resolve this would be great!

So i bought the black forester XT that the PO said would not run and when it did it would run rich. I got it with the intention of putting a different motor in but decided since it was recently imported and installed it would be worth while to try and Diagnose the problem.

With a charged battery it turns over but does not idle. When it did idle for 8 seconds it sounded like it was running on 1 or 2 cylinders.

So i changed the spark plugs and checked the coilpacks. Old plugs were totally fouled and the packs were fine.
During the test of the coils i had disconnected the #3 fuel line coming off the fuel filter into a small gas tank on the floor so that the motor does not fill with gas while the engine was being cranked with the coils out.

After putting the #3 fuel line back on, new plugs in place, and coils on again, IT STARTED!:grin2: and idled fine for awhile, even reved it a couple times and said wow i cant believe it was that easy.
turn it off, finish putting the airbox back in and clean up to roll it outside and see if i can move it around the block.


This time when i try to start it, i get the same issue as the original problem. So i decided to disconnect that fuel line i had pulled in the first place. and again IT STARTS? and it continued to idle for about 25 seconds till the fuel that was some how getting to the injectors ran out.
I can reproduce this issue by just clamping that fuel line, with it clamped it will idle fine, the second I ether take the clamp off or touch the pedal the engine instantly dies.

TLDR
The engine will idle when I pinch the pictured #3 fuel line, but not when i let go.
If the line is pinched, with pliers, i can start it and get it to idle

attached youtube video shows what happens when you keep the line pinched and let go.

youtu.be/b4WdMb2QW_Y
 

Attachments

·
Registered
2004 Forester XT Auto Automatic
Joined
·
9 Posts
Discussion Starter #2
In case someone in the future finds this post.

Turns out the maf sensor was bad, swapped with a know working one and problem solved.
Also to help your diagnosing, just unplugging the maf allowed the car to idle.

Have a good one!
 

·
Registered
2004 Forester XT
Joined
·
37 Posts
@austencamm Hello

By the way what injectors are you running in the ej20x's , I am doing a swap now from a ej255 to ej20x and was wondering which one has the bigger injectors, I think the ej255 are yellow and the ej20x are blue, can you confirm?

Thanks
 
1 - 5 of 5 Posts
Top