Subaru Forester Owners Forum banner

1 - 14 of 14 Posts

·
Registered
2008 Forester
Joined
·
65 Posts
Discussion Starter #1
helloo everyone, computer analysis said my car's EGR Valve is throwing Check engine light. i would like to clean it myself with basic easy to get cleaning product? what should i buy to clean it? there's no special shops that sell proper checmicals to clean such stuff near where i live. also where is the EGR valve on EJ20 engine? thanks:wink2:
 

·
Registered
Joined
·
6 Posts
You can screw it off while engine is turned off, clean it with active hydrocarbon cleaner. Seafoam or egr cleaner like forte cleaner, do you have thinner solvent?

If you have a turbo model, you can let it written out.
 

·
Registered
2008 Forester
Joined
·
65 Posts
Discussion Starter #4
today i took it off cleaned it put it back and after a while driving mixed speed above 50kph chech engine lights are back. also power is weak recently when going up. :|
 

·
Registered
2008 Forester
Joined
·
65 Posts
Discussion Starter #5
changed egr valve 3 times and check engine light is back. what else would it be?
 

·
Registered
2008 Forester
Joined
·
65 Posts
Discussion Starter #6
gi everyone. I got EGR valve light and would like to block it off with a alu plate or coca cola can. if i connect the EGR on to the solid gasket will i get EGR check engine light? mine is non turbo engine 2.0
 

·
Registered
2008 Forester
Joined
·
65 Posts
Discussion Starter #7
can someone please guide me through EGR parts locations. mine is definetely not the egr valve as i changed a few times and light comes on. i cant seem to find EGR pipe ...
 

·
Registered
2010 Forester 2.5 XPremium 4EAT
Joined
·
861 Posts
Let's start at the beginning. What codes are you getting? Post those and more people will be likely to help you.
 

·
Registered
2008 Forester
Joined
·
65 Posts
Discussion Starter #9
Let's start at the beginning. What codes are you getting? Post those and more people will be likely to help you.
P0400. egr trouble code shows up even after bare engine swap as well as tried changing the valve 3 times already and the issue still persists.
 

·
Registered
2010 Forester 2.5 XPremium 4EAT
Joined
·
861 Posts
Have you checked the condition of the hose that connects to the valve? They can get brittle over time and not function correctly, which could also cause that code.
 

·
Registered
2010 Forester 2.5 XPremium 4EAT
Joined
·
861 Posts
You might want to have a read of these threads



 

·
Registered
2008 Forester
Joined
·
65 Posts
Discussion Starter #13
Have you checked the condition of the hose that connects to the valve? They can get brittle over time and not function correctly, which could also cause that code.
Hey there thanks. I cant seem to find those hoses except the main valve. Can you show where those hoses attached? Also used cheap ODB 2scanner to test the results.
524893
524894
524895
 

·
Registered
2010 Forester 2.5 XPremium 4EAT
Joined
·
861 Posts
@Bovka

I do aplogise, I misread your original post. I thought you were talking about a PCV valve, hence me mentioning about the (breather) hose. I made the same mistake when I made my own thread about PVC valves, it's part of my dyslexia condition.

You've got some great photos there. Hopefully someone will be able to help, although many owners have had the same code as you and not been able to work this out, as evidenced in those 3 threads I posted for you.

You need to specify exactly what vehicle you have and year, people will be able to assist you better.

It's one of the big PIAs of this new - crap - version of this forum; no-one can easily tell anymore what vehilcles people own.
 
1 - 14 of 14 Posts
Top