Subaru Forester Owners Forum banner
1 - 1 of 1 Posts

·
Premium Member
2004 FXT 5MT
Joined
·
48 Posts
Discussion Starter · #1 · (Edited)
I recently finally got around to doing the resistor mod for a catless up pipe because my state inspection is due. Funny story, while I was doing the up pipe I snipped the wire to my heater sensor. Soldered it back but it fell apart recently and was getting a P0132. Got a new sensor, installed it fine, and reset my ECU; ready to get the state inspection done. So I thought.

They came back with 2 monitors not ready. Catalyst and evap. So I drove it a bunch (approx. 500 miles or a tank and a half of gas) and routinely was checking on my OBD. Always showing INC, never OK. I (probably) stupidly (against the advice of the service shop) reset my ECU and have been trying again. About a tank of gas so far and still nothing. Is there some sort of driving condition I have to meet? The CEL never came back on and my repairs seem fine. What's going on?

EDIT: false alarm either the ecu reset worked or the 1/4 to 3/4 full petrol tank drive cycle worked
 
1 - 1 of 1 Posts
Top