Subaru Forester Owners Forum banner

1 - 14 of 14 Posts

·
Registered
2004 XT Manual
Joined
·
837 Posts
Discussion Starter #1
Hi guys and girls,

can anyone confirm whether there should be any dash lights that illuminate when cruise control is switched on and when in use? Manual suggests there is but I have neither the 'Cruise' light or the 'Set' light on the dash. Not really sn issue but curious!
 

·
Registered
05 XT2.5
Joined
·
1,978 Posts
You should see 'cruise' and 'set' in green on the dash. Set goes out when it's working. I think. I use it rarely because some nitwit is always getting in the way.

I also doubt it's more economical than 'foot' control.
 

·
Registered
2004 XT Manual
Joined
·
837 Posts
Discussion Starter #3
You should see 'cruise' and 'set' in green on the dash. Set goes out when it's working. I think. I use it rarely because some nitwit is always getting in the way.

I also doubt it's more economical than 'foot' control.
Cheers mate. I'll have a look to see why they aren't coming on. I use cruise quite a bit as i'm forever chugging up and down motorways at 0500.
 

·
Registered
2005 XTEn Auto
Joined
·
1,139 Posts
If I remember rightly my old 03 XT only had a light on the switch. My 06 model has CRUISE and SET because the switch is on the end of the stalk.

Max.
 

·
Don, King of the parts diagram
MY11 WRX STi Sedan 6MT
Joined
·
5,575 Posts
If I remember rightly my old 03 XT only had a light on the switch. My 06 model has CRUISE and SET because the switch is on the end of the stalk.

Max.
Max is partially correct the 03 has the amber light on the switch, and an amber "cruise" light in the combimeter.

You've checked out page 7-19 of your owners manual.

My main switch doesn't have any illumination and its a dismantle switch to fix.

You may want to check fuse No18 (15A) in the fuse box by your right knee behind coin box.
 

·
Registered
2004 XT Manual
Joined
·
837 Posts
Discussion Starter #8
Max is partially correct the 03 has the amber light on the switch, and an amber "cruise" light in the combimeter.

You've checked out page 7-19 of your owners manual.

My main switch doesn't have any illumination and its a dismantle switch to fix.

You may want to check fuse No18 (15A) in the fuse box by your right knee behind coin box.
Cheers Don,

Yeah, checked the manual first hence my question. I'll have a gander at the fuse in the morning as i have only just got in from bloody work.
 

·
Don, King of the parts diagram
MY11 WRX STi Sedan 6MT
Joined
·
5,575 Posts
OK guys.....led you on a bit of a goose chase. Haven't actually used cruise for years. Only went on the manual :icon_frown:

It would appear that the dash light is not used for the "UK market" and the corresponding bulb socket fitted with an ordinary green illumination bulb.

Here is the bulb diagram for the combimeter



Ben,
If the cruise isn't working check the fuse.
If it does then to replace the switch illumination bulb it means taking the switch to pieces or a new switch.
 

·
Registered
2004 XT Manual
Joined
·
837 Posts
Discussion Starter #13
I had a feeling this was the case.

My cruise is working fine as is the illumination on the switch. I was just missing the dash lights which were non-existent anyhow!

Problem solved.

:icon_biggrin:
 

·
Emeritus Forum Staff
2015 Triumph Tiger XCx 1 Down. 5 Up.
Joined
·
5,242 Posts
and there was me thinking we'd identified a reliability issue! ;o)
 
1 - 14 of 14 Posts
Top