Subaru Forester Owners Forum banner

1 - 7 of 7 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
As the title states I'm having some cruise control issues. Basically I'll set the cruise at let's say 72mph, and it sets, and holds for a while. Then all of a sudden it just shuts off on it's own. Same feeling as though you were to hit the cancel button. The light stays on and it can be re-engaged, but still it just stops cruising on it's own. I've noticed this at 75mph before, but I figured it was just the puter telling you, you shouldn't have the cruise sat at that speed which is fine. Anyways, any ideas or comments? Anyone else have this problem? I'm at 65k now :)
 

·
Registered
2010 FXT Limited 4EAT Sport Shift
Joined
·
1,461 Posts
sleeper42-
First, were there already 41 forum members with the sleeper appelation ahead of you?
Re Cruise Control, this topic has had previous exposure in 'old forum'...it seems to be limited to manual transmission models, and if I recall correctly, associated with a switch on the clutch...don't recall a solution though...
-Quick
 

·
The Modfather
2019 Impreza 5dr Sport - Manual
Joined
·
8,052 Posts
I seem to remember it being the clutch safety switch too. It would be worth a look. I'm just about to catch a plane so I can't look it up right now. If I have access where I'm going I'll check then. If not see you guys in a week...

Good luck
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #4

·
Registered
2006 2500X
Joined
·
113 Posts
In my area the roads are with lots of bends plus ups & down for the roads are hacked out of the mountian sides being many two lane with some four lane. Have only tried the Cruise Control & satisfied to go back to using my throttle. Probably a habit from prior cages without cruise control, plus I ride m/cs most of the time.
 

·
Premium Member
12 Premium 5-speed
Joined
·
4,486 Posts
The switch is located on the transmission itself, I believe on the big ol' housing where it connects to the drive shaft - there are two switches there and I'm not certain what the other one does. I hit up my parts guy last weekend and asked where the thing is located and he flipped the screen around and showed me. I haven't gone under the car to look yet. God forbid I ever get enough time at home to actually take it in to the dealer for a look-see under warranty...

The simple solution is to lightly hold the shifter up and to the right while cruise is engaged. I've joked with my wife that I'm going to attach a long rubber band to the inside of the glove box and let that thing do the holding for me. :biggrin:
 

·
Registered
2010 FXT Limited 4EAT Sport Shift
Joined
·
1,461 Posts
sleeper42 said:
I did the dumb newbie thing and didn't utilize the search. Apparently there is a neutral switch that could be causing this. Any ideas on where to find the switch, that's the one part I could not find in the search. I found this thread though: http://www.subaruforester.org/vbulletin/forums/showthread.php?t=1479&highlight=neutral+switch

Thanks for the help.

Quicksilver, the 42 has it's own meaning to me, and no it's not my age...lol
Sleeper42-
Just curious, on another forum, I'm SleeperXTc...(which is a state I'd attain if I manage to go FMIC (front mounted intercooler) and replace hood...:>}
-Quick
 
1 - 7 of 7 Posts
Top