Subaru Forester Owners Forum banner

1 - 6 of 6 Posts

·
Registered
04 Forester 2.5XT
Joined
·
107 Posts
Discussion Starter #1
After I put the phenolic spacers and silicon inlet on, I started getting 2 codes. P0546 and p1312. Basically my EGT crapped out. The only engine mods I have are STI cat-back, STI IC, inlet, and spacers. I can't figure out why this would have killed my EGT but the timing is too coincidental for me to think otherwise. Anywho, after searching, I see a lot of people just pull the EGT, plug the hole and do the 2.2k resistor thing.
My thing is this, does the car really use the EGT in the ECU tuning? I would hate to be running lean and not know it. I will probably get an aftermarket EGT since i'll be upgrading to a VF39 but for now it'll be stock. Is it safe to assume that the car tunes itself just fine using all of it's other sensor inputs that I don't need the EGT hooked up? Any input would be great, thanks.
 

·
Registered
none none
Joined
·
8,844 Posts
The stock EGT sensor is there mostly to keep the stock uppipe cat happy. I'd recommend swapping in a catless STI uppipe or similar and then just throw the resistor in the harness (i've had mine that way for around 40,000 miles). I'd definitely do it if you're going vf39.
 

·
Registered
2008 GRB 20th anniversary 6 MT
Joined
·
6,570 Posts
Do Foresterrs have EGT sensors fitted from factory?!
FSTI don'tn have a cat in the uppipe AFAIK.
 

·
Registered
04 Forester 2.5XT
Joined
·
107 Posts
Discussion Starter #5
The up pipe cat is about to get deleted anyway. I just picked up a resistor and I'm going to solder spade terminals on it to plug into the plug. Should be good to go by tonight.
 
1 - 6 of 6 Posts
Top