Subaru Forester Owners Forum banner

1 - 11 of 11 Posts

·
Registered
2004 Forester XT 5MT
Joined
·
942 Posts
Discussion Starter #1 (Edited)
Alright hopfully this is a simple fix. Got some oil pooling up directly underneath my throttle body and i can't seem to get it fixed! now here's what i've discovered, there is a hose connectiong the block to a black are line that i know the oil is seeping from so i know where the leak is just unsure for a fix since i worm clamped it really tight and STILL oil blows throw! so i'm confused why i'd be getting that much positive crank press out of complete no where!!! any help guys would be fantastic!
Thanks

[/URL][/IMG]
 

·
Registered
2008 OBXT
Joined
·
101 Posts
This may be a stupid question, but is your PCV valve working?
I know from previous cars that a clogged PCV valve can lead to significant pressure build up and result in all kinds of problems, including oil leaks.
 

·
Registered
2004 Forester XT 5MT
Joined
·
942 Posts
Discussion Starter #3
it's brand new, and the odd thing is... it's not hooked in with the PVC it's hooked to a different hard line that hooks up next to the breather lines that go accross the IC.
 

·
Registered
2008 OBXT
Joined
·
101 Posts
Sorry, I'm not familiar with how the XTs are plumbed, just thought I'd help with eliminating the obvious first.
Maybe a pic would help others help identify the problem?
 

·
Registered
2004 Forester XT 5MT
Joined
·
942 Posts
Discussion Starter #6
I'm thinking it's suppose to be hooked to a vaccum of some form. but it is blowing oil from it like crazy!!!
 

·
Registered
2009 Forester X Premium
Joined
·
3,091 Posts
Can you take a picture of where its leaking?
 

·
Registered
2004 Forester XT 5MT
Joined
·
942 Posts
Discussion Starter #9
K so found a pic, and the yellow circle is highlighting the hose i'm having issues with. it's blowing oil from the block side connection.
 

·
Registered
2007 FXT Sport M5
Joined
·
78 Posts
You must be getting a lot of blow-by to get that much pressure. Is your A/F ratio good or are you running lean and buring your piston rings?
 

·
Registered
2004 Forester XT 5MT
Joined
·
942 Posts
Discussion Starter #11
A/F are good, the only thing is i had the breather line unhooked to the turbo inlet so it wasn't getting vaccum. but not its reconnected and still doing it so some on nasioc think i blew out the hose and it needs replacing.
 
1 - 11 of 11 Posts
Top