Subaru Forester Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2003 Forester XS
Joined
·
236 Posts
Discussion Starter #1
I had the check engine light come on a couple days ago so I pulled into Advanced to uses their code reader and it kept getting an error in communication. So I went to autozone to try theirs and got the same. I am hesitant to pay 100 bucks for the dealer to try and just get the same problem. Any ideas? My only guess is a loose ground or wire somewhere, I just haven't had any time to track it down.

Thanks, O
 

·
Registered
Joined
·
6 Posts
not all scanners will work on subarus. I had the same problem here at the shop and some of the guys here told me that the scanners we have will not work on my car. so i just went to autozone and had them pull the code with one of there scanners. I dont remember which scanner they used tho. So just try going to an Autozone or something.
 

·
Registered
2003 Forester XS
Joined
·
236 Posts
Discussion Starter #7
Make sure that the ignition key is turned to ON and not ACC. With the key turned to ACC the reader will still turn on and attempt to connect but in ACC mode you'll get the exact error you stated.
that might just be something stupid enough for me to do. I thought it wasn't but worth another try! Thanks
 

·
Official sf.org decal guy
2006 FXT
Joined
·
12,516 Posts
that might just be something stupid enough for me to do. I thought it wasn't but worth another try! Thanks
Stupid enough for you to do??

I have had my own code reader for many many years and last week I couldn't figure out why the hell the reader was not communicating with the car :lol:
 
1 - 8 of 8 Posts
Top