Subaru Forester Owners Forum banner
1 - 5 of 5 Posts

·
Registered
2006 Forester LL Bean edition
Joined
·
2 Posts
Discussion Starter · #1 ·
I have poor idle, poor acceleration up to about 1500 rpm's and code P0336 every other time i start the car. After I clear the code, it runs better. I changed the timing belt, and this started. I have checked the belt twice since install and it is dead on. I changed the crankshaft position sensor and no change. There is one tooth broke off the crankshaft gear, could that be my problem?
Any advice is helpful, I am out of ideas.
Tire Wheel Automotive tire Light Tread


Sent from my SM-N960U using Tapatalk
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
41,769 Posts
@butwutami welcome to the forum from Oregon!

No expert on this, but I believe that broken tooth, looks like a fresh break, is part of the Crankshaft Position Sensor circuit, so that could be the cause of your P0336?

Bobby...

['07 FSXT Member Journal] ['03 X Member Journal]
 

·
Registered
02 wrx 06 sti 06 legacy gt 09 forester 13 legacy 3.6r
Joined
·
22 Posts
I have poor idle, poor acceleration up to about 1500 rpm's and code P0336 every other time i start the car. After I clear the code, it runs better. I changed the timing belt, and this started. I have checked the belt twice since install and it is dead on. I changed the crankshaft position sensor and no change. There is one tooth broke off the crankshaft gear, could that be my problem?
Any advice is helpful, I am out of ideas.
View attachment 561232

Sent from my SM-N960U using Tapatalk
The broken tooth is the problem. You will need to replace
 
1 - 5 of 5 Posts
Top