Subaru Forester Owners Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I had code P0107.
I replaced MAP sensor and voltage from map sensor to ecm is 1.25 in idle
After replacement I have codes P0107 and P0108 using INNOVA 3160 scanner
I cannot erase this codes, they come again and again Map sensor input voltage is 5v
Any help appreciate
 
2017 2.5i Fozy CVT
Joined
·
1,283 Posts
Is it correct to assume that the scanner can erase codes?
Is the MAP plugged in to the intake or connected by vacuum line?( not familiar with this sensor)...
The wiring is all in good condition, air cleaner new, no breaks or loose connections in stock air intake?
Vacuum lines all in good condition?
 

·
Registered
non-subaru
Joined
·
911 Posts
I think most map sensors are basically potentiometer (basically a variable resistor) with three connections: one side goes to a reference voltage (your 5V) , the 'variable' part is your 1.25V and the other side should go to a level close to ground. It likely goes back into the ECU but it probably is tied to ground there.
You may want to make sure that ground leg is indeed tied to ground. Do more than measure voltage at that point because, should it not be connected, it will measure 0V and fool you into thinking it is ground. Instead, measure connectivity (ohm setting).
 

·
Registered
2012 Forester 4 speed auto
Joined
·
1,128 Posts
Perhaps there was never anything wrong with the MAP sensor. Check to see if there is vacuum in the hose from the intake manifold that is connected to the sensor. Perhaps, a hole in the hose or a large vacuum leak in the manifold.
 
1 - 4 of 4 Posts
Top