Subaru Forester Owners Forum banner
1 - 9 of 9 Posts

·
Registered
99 s turbo
Joined
·
97 Posts
Discussion Starter · #1 ·
Hi all, I brought a boost gauge this week and checked what I was running, it's saying 6 psi, then I disconnected the bcs and it's still saying 6 psi, bcs prob? I also brought dumpvalve of a sti but it doesn't go on, there's an elbow on it and can't get the pipe over it, how can I make it fit, thanks.
 

·
Registered
2006 Forester XT
Joined
·
657 Posts
Disconnecting the bcs will leave you with a maximum boost as set by the wastegate spring, so six is about right.

The fact that you don't get any more than six may be a bad solenoid.

S
 

·
Registered
99 s turbo
Joined
·
97 Posts
Discussion Starter · #4 ·
Disconnecting the bcs will leave you with a maximum boost as set by the wastegate spring, so six is about right.

The fact that you don't get any more than six may be a bad solenoid.

S
i did actually clean the bcs a week ago, i pluged the 2 green plugs under the dash and the bcs starting clicking, then i sprayed some clutch cleaner through it and it was pumping through, could it still be faulty or could there be another problem some where else, can any1 give me info on the ghetto boost mod, ill try it and see if theres any difference, thanks
 

·
Emeritus Forum Staff
2015 Triumph Tiger XCx 1 Down. 5 Up.
Joined
·
5,242 Posts
Check for blockages in the turbo pipework and that you have a restrictor pill in the pipe from the turbo outlet to the T piece... either of these could stop the BCS from being able to vent off enough air to prevent the wastegate from opening before target boost.
 

·
Registered
99 UK S-turbo
Joined
·
8,566 Posts
Also worth doing the free BOV fix....and you can only realistically fit the right BOV for the car you have.

Simon
 

·
Premium Member
98 JDM Stb Manual
Joined
·
3,787 Posts
Does it mean I can use the hammer and chisel again?
 

·
Registered
99 s turbo
Joined
·
97 Posts
Discussion Starter · #9 ·
there was no restrictor pill in the pipe where it should be, so i went and brought a mig weld tip with a 0`.8mm hole, and that brought the boost upto 11 psi:icon_biggrin:, but how would i know what the ecu boost should be as i might be over boosting, bearing in mind i have the ppp but dont know what it should be , what problem would over boosting cause, the bov iv got of an 04 sti fits onto the intercooler the same way as my stock one, but it has an elbow where i have to coonect the recirc pipe , the elbow has 2 screws so i undone them and turned the elbow around, now i just need a pipe. i had it on for a while venting to air, but i put the original 1 back on and have noticed some stuttering so i think that may be leaking as it never stutterd with the sti 1.
 
1 - 9 of 9 Posts
Top