Subaru Forester Owners Forum banner

1 - 20 of 44 Posts

·
Registered
Joined
·
341 Posts
Discussion Starter #1
Had Bob do the final map for now and this was the result.



Look forward to your comments.

Mog
 
A

·
Guest
Joined
·
0 Posts
Delta dash road dyno?
Mine made 311 / 310 on delta dash and 282/280 on the rollers the next week..
 

·
Premium Member
2008 Forester Cross Sport AUTO
Joined
·
4,596 Posts
Crikey, is that more than NDS??


What blower do you have by the way??


Andy, why the difference on the 2 readings??


Cheeers.

Regards



AM
 

·
Mad Englishman.
MY06 Forester STi 6MT
Joined
·
4,157 Posts
That can't still be a VF41 - full boost at 4,000 revs.?!? Did you switch the the MD321T...?

Come on, spill the beans matey !

:woohoo:
 

·
Registered
2008 GRB 20th anniversary 6 MT
Joined
·
6,570 Posts
This car was already fitted with a MD321, wasn't it? ;)
 

·
Registered
05 XT2.5
Joined
·
1,995 Posts
<Andy, why the difference on the 2 readings??>

Mine made 340 on delta dash with the old turbo. On the rollers it was 20 something short. Mind you they're always better on the road than the drums.
 

·
Registered
2008 GRB 20th anniversary 6 MT
Joined
·
6,570 Posts
I would be interested to see how it drives :)
 

·
Registered
2014 Audi S4 Black Ed Semi auto
Joined
·
439 Posts
Knowing Bob, that will drive lovely.

I used to own one of Bob's old Impreza's, and we only just managed 400 square out of that. So im very impressed.
 

·
Registered
Joined
·
341 Posts
Discussion Starter #12
Very long story in short, but the FSTi was bought from Marky last year with a known fault which was susposed to have been fixed and was apparent as a hesitation when accelerating this after sending it to Litchfield/APi turned into a destroyed bottom end due to the 740 injectors having the wrong spray pattern coupled with opensource software all supplied by Zak @ Mocom who disconected the Lambda sensor on the last visit in order to cover up the fault !!!!

To be fair to Marky he made a good will gesture which would have involved a liner in no.4 cylinder which was the first sign of problems and I accepted and the matter was therefore closed from his point of liability. However when the engine was stripped down it was found that the bores were ovaled and a new short block was needed, at this point I decided upon a forged bottom end as we wanted to keep the car.

A new short block was ordered from Subaru which was then stripped down and the appropirate parts replaced with cosworth items, this was then reassembled and a bespoke map from Ecutek to try and control the 740 injectors for running in.

This brings us to date, the 740 injectors have been replaced with 550 injectors as these are the largest side feed available from a reliable source, there was talk of converting to top feed 650 injectors but this involved custom rails and the inlet manifolds being changed at a prohibitive cost.

The turbo is a MD321H running at 1.5 bar Peak however the 550 injectors are running at 92% and there is a restriction at 5500rpm which is preventing the full potential of the setup, that said the foz runs extremely well now and is very fast and smooth so prob wont pursue this much more on the basis of more money spent for little gain.

The Car is going on the rollers this week and so hopefully will have a graph to compare to the delta dash.

Mog
 
A

·
Guest
Joined
·
0 Posts
I can only dream of that kind of power in my old shed, nice setup Clive :biggrin:
 

·
Mad Englishman.
MY06 Forester STi 6MT
Joined
·
4,157 Posts
Interesting. Just punted my potential next upgrade that was all nicely scoped out into touch for sure !


:confused::huh::confused:
 

·
Registered
2008 GRB 20th anniversary 6 MT
Joined
·
6,570 Posts
turned into a destroyed bottom end due to the 740 injectors having the wrong spray pattern coupled with opensource software all supplied by Zak @ Mocom who disconected the Lambda sensor on the last visit in order to cover up the fault !!!!
Mog
So was the car running without the lambda sensor before the engine failed?! :crazy:
 

·
Registered
Joined
·
341 Posts
Discussion Starter #18
So was the car running without the lambda sensor before the engine failed?! :crazy:
Sensor was disconected and the CEL light on the dash was disabled so we wouldn't know unless specifically looking for it, this would have been done via a laptop and so quite deliberate.

Mog
 

·
Registered
2008 GRB 20th anniversary 6 MT
Joined
·
6,570 Posts
Sensor was disconected and the CEL light on the dash was disabled so we wouldn't know unless specifically looking for it, this would have been done via a laptop and so quite deliberate.

Mog
really!?! Did you manage to prove this to them and what did they say?
 
1 - 20 of 44 Posts
Top